MacBook Air missing EFI partition

Discussion in 'MacBook Air' started by Jonathanchasr, Jan 17, 2014.

  1. Jonathanchasr macrumors newbie

    Joined:
    Nov 18, 2013
    Location:
    NJ
    #1
    Today I tried to install Ubuntu on my mac and screwed up the drive and now In recovery I can't even erase my drive it says missing efi partition and failed to unmount when I choose one partition. I tried going to single user mode and repairing the drive but that didn't work I have a 2013 Haswell i7 13 Air. I'm going to try and boot from a Bootable mavericks Recovery USB and see if that helps to erase the whole SSD. Can anyone give me some tips.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    You can boot to Internet recovery without a USB key on your machine. Just hold command-option-r when booting and it will ask for your wifi password. After that you will see a spinning globe while the recovery utility downloads from Apple's servers. Once that is done you will see the normal recovery console.

    Start Disk utility and select the drive it self at the very top (above Macintosh HD) and erase the entire disk in Mac OS Extended format.

    Then quit Disk Utility and click reinstall OS. That will download and install the OS your Mac came from the factory with.

    The full disk format and reinstall will get you back your EFI partition.

    Of course this will wipe all your data, so hopefully you have a backup.
     

Share This Page