Macbook Air no longer displays 2560x1440 on external monitor

Discussion in 'MacBook Air' started by Drmedic1, May 11, 2016.

  1. Drmedic1 macrumors newbie

    Joined:
    May 11, 2016
    #1
    Background.

    I have a MacBook Air (13-inch, Mid 2012) Version 10.11.4.
    I own a 27" BenQ GW2765 monitor.

    I have had few problems using this monitor for ~2.5 months - using it at maximum resolution. There have been blips where the monitor has not been detected, but I just shut both the laptop off and monitor off for a few minutes, and the problem is resolved.

    Last night, I left my set up all connected, my laptop in sleep mode. I woke up this morning to find my screen in 1080p. I thought this was a bit odd, so I tried to change it back to 2560x1440. And the screen just changes (see picture).
    Every other resolution seems to work. From 480p to 2048 x 1152. What I can't get my head around is why it won't work on 2560 x 1440 anymore. I have no updated anything, didn't download anything. I've tried changing the miniDP-DP cable, SMC/PRAM reset to no avail. Does anyone have any clue why this is happening? I've googled it, but cannot find a reason (nevermind a solution) to why this is occuring.
     

    Attached Files:

  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Go to the display's menu and make sure that the settings are right. I know you didn't change anything, but there's a chance the display did something on its own due to a power down for instance.

    Do you have any other hi-res display you could try (at a friend's place etc)? Since you've already tried a different cable as well as SMC/PRAM resets, it seems that the issue is either the MBA or the display. I'm inclined to say it's the display, but that would be the best way to try it out.
     
  3. Drmedic1 thread starter macrumors newbie

    Joined:
    May 11, 2016
    #3
    Thanks for your reply. I thought it was the monitor, so I got a replacement monitor (same monitor), and the same problem occurs. I will test this with another Macbook later today, and if that works fine, then it's probably my Macbook :(
     
  4. MuggeGHQ macrumors member

    MuggeGHQ

    Joined:
    Aug 25, 2008
    #4
    Hi



    What worked for me was this.



    I bought a Thunderbolt/Mini Displayport to Displayport cable v1.2 (4k compatible)

    I also used the http://embdev.net/topic/284710 but i'm not sure it was even necessary

    in my situation.

    I'm on the latest Sierra 10.12.3 so maybe it is fixed now.

    But everything looks fine now on my Dell U2723HM and Macbook Pro 15" Retina.

    Hope this helps. I was also in the same situation as everybody else with only Full HD

    resolution but now i have 2560x1440 and it looks great.
     

Share This Page