Macbook Air not updating, errors

Discussion in 'MacBook Air' started by thetrumanator, May 27, 2012.

  1. thetrumanator macrumors newbie

    Joined:
    Apr 17, 2011
    #1
    Ok, so earlier today I was trying to update to 10.7.4, and multiple times I got the error the Mac OSX update could not be expanded, and corrupted during download. PLease try again. I tried over and over to get it to work, manually downloading it, resetting pram, smc, and repairing the disk and disk permissions in recovery mode. All of this to no avail. So I was trying to partition the hard drive to find out what was going on and accidentally deleted my entire hard drive. I didn't have anything important on it so Im not sad there, but when it was time to install lion, I went through all of the steps and license agreement, and tried to download it. I did this twice and it got stuck in an eternal download loop, not downloading anything. This is odd because I have 40 mBits internet. It was not my internet as I could use it on every other computer. So I broke out my old snow leopard install usb drive, and now have snow leopard. But now it won't install updates either. I performed hard drive checks and it all says it's all right. I also completed a quick hardware scan and nothing came back. RIght now Im running an extended test. I NEED SOMEONE TO HELP ME!!!! I have no idea whats wrong and my warranty ran out because I couldn't afford it at the time.
    Thanks to anyone,
    Truman

    ----------

    the extended test just finished and found no problems. I can use the computer just fine for internet and stuff but cannot download updates, and now Im stuck in snow leopard
     
  2. Puevlo macrumors 6502a

    Joined:
    Oct 21, 2011
    #2
    Well it looks like there is definitely an issue with it connecting to the Internet as both errors relate to the integrity of the downloaded data. I'd suggest trying another wifi connection otherwise might be your airport card is busted.
     
  3. thetrumanator thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #3
    oddly enough i downloaded a torrented lion and it installed fine, and i just updated it to 10.7.4 from a torrent with no errors. I am thinking apple doesn't recognize the device as an apple so it won't verify downloads. If this is the problem how is it fixable. I always get solid downloads and had no interruptions downloading the lion torrents
     

Share This Page