Macbook Air Refuses to Boot from CD or USB

Discussion in 'MacBook Air' started by sdee11, Sep 30, 2011.

  1. sdee11 macrumors newbie

    Sep 30, 2011
    I have a massive problem with a new Macbook Air. It already came with Lion but I intended to install Snow Leopard, so performed a hard disk erase then proceeded to boot from a Mac Software USB drive but when holding down C it kept hanging at the Apple Logo Screen, no spinning wheel. Then I tried a SL DVD instead but instantly goes to a Kernal Panic (Unsupported CPU error)

    Command-R doesn't seem to work anymore and Internet Recovery also keeps failing. I've ran an Apple Hardware test and everything comes back as ok. I've resetted the PRAM/NVRAM and SMC which hasn't made any difference

    I'm completely out of ideas what to try next, I'm led to believe this could be the cause of a failed hard disk?
  2. KPOM macrumors G5

    Oct 23, 2010
    The only way to get Snow Leopard working on the new model is to run a copy of Snow Leopard Server in virtualization (Parallels Desktop and VMWare Fusion support it). You need the server version, though.
  3. rowley macrumors 6502


    Dec 16, 2008
    London, UK
  4. deeddawg macrumors 604

    Jun 14, 2010
    Looks like you pooched it. As mentioned above and in many other threads, Snow Leopard will NOT install on a 2011 Macbook Air. No way around it but to run it in virtualization.

    It's strange that the Internet Recovery isn't working. Check this Apple support page and verify your network setup matches what's supported.

    If ALT-Command-R *still* doesn't work, sounds like it's time for a call or visit to Apple.
  5. GekkePrutser macrumors 6502a


    Aug 18, 2005
    I had the same issues with the Internet Recovery after I wiped my 11" to return it.

    One thing I noticed: Internet recovery does not work with the USB Ethernet Adapter. It seems to start but it 'hangs' with an estimated completion time of 24:00 hours.

    It is also picky on WiFi access points, even repeatedly entering the password did not get it into mine. I tried another access point and that worked.

    You could also try disabling the WEP/WPA security while it's loading the initial recovery image but don't forget to turn it back on afterwards of course.
  6. sdee11 thread starter macrumors newbie

    Sep 30, 2011
    Thanks for your replies. I didn't realise it wasn't possible to downgrade to Snow Leopard. If I make a Lion Bootable USB Drive, is there a chance this will at least let me reinstall?
  7. Macman45 macrumors G5


    Jul 29, 2011
    Somewhere Back In The Long Ago
    I Doubt It

    But it's worth a try. I feel a large slice of humble pie and back to the store though.
  8. deeddawg macrumors 604

    Jun 14, 2010
    Yes, but not using the Lion install from the App store; the version in the App store doesn't work on the 2011 Air at this time I believe. You'd likely need a friend to pull down the Internet Recovery version on a different 2011 Air using this technique described here:

    What is strange though is that your computer won't work with Alt-Command-R. It should come up with a "Starting Internet Recovery" and a spinning globe on the screen.
  9. wrinkster22 macrumors 68030


    Jun 11, 2011
  10. extramindful macrumors newbie

    Oct 8, 2011
    I cannot do diagnostic work nor can the Apple Store on Mid Macbook Air because NONE of these Macbook Airs will not USB Lion boot from an external disk. Apple does not appear to know of this issue. At the Apple Store we also tested the Macbook Airs at the store, and they did NOT boot from various USB devices. The Apple Store said there should be a firmware update to correct this issue. All my external formatted Lion disks will boot fine on my iMac. Wonder if thunderbolt will help?

Share This Page