MacBook air stuck on grey screen/apple logo/loading wheel

Discussion in 'MacBook Air' started by Tagnco, Jun 12, 2011.

  1. Tagnco, Jun 12, 2011
    Last edited: Jun 12, 2011

    Tagnco macrumors newbie

    Jun 12, 2011
    I'm new to Macs- just purchased this 13" Air off of eBay in March. It's been running great. Today when I started it up, it wouldn't go past the grey screen, apple logo/ spinning loading wheel.
    I went to apple's website and tried the different troubleshooting tips and also removed the battery, etc. Still the same.
    I looked through the posts here and am in the process of trying the Safe Mode boot. At the end of the Fsck -fy it says:
    ** The volume Macintosh HD could not be repaired after 3 attempts.

    Any suggestions?

    Now it's backto the grey screen/logo/wheel thing "/

    Edit: I typed reboot
    Now I am getting a bar below the wheel which is loading as I type...
  2. Hellhammer Moderator


    Staff Member

    Dec 10, 2008
  3. Tagnco thread starter macrumors newbie

    Jun 12, 2011
    Thank you for the reply :)

    Just an update: I did the Fsck -fy again and very quickly it checked an said the Macintosh HD was good.
    So I'm rebooting, but have the same grey screen.

    I'm going to follow the steps in your post's link.
    Thanks again.
  4. setasai macrumors member

    Apr 25, 2005
    I would skip the hassle and just take it to the Apple Store. Either they tell you that the OS installation got corrupted and needs to be reinstalled (which you can do yourself) or the SSD is busted and needs to be replaced.
  5. Tagnco thread starter macrumors newbie

    Jun 12, 2011
    I suppose I will have to take it in bc I didn't receive any reinstall CDs with the Mac.

Share This Page