MacBook Air trackpad tap to click unresponsive after sleep?

Discussion in 'MacBook Air' started by mixvio, Nov 20, 2010.

  1. mixvio macrumors 6502

    Joined:
    Apr 12, 2009
    Location:
    Sydney, Australia
    #1
    I just got a 13" MacBook Air and I'm having an issue with it; googling around I've seen slightly similar problems, but nothing identical to what is going on with mine.

    I have the trackpad set to use the "tap to click" option in System Preferences and I've noticed that after I sleep the machine and wake it again, something gets bungled with it. The tap to click either stops responding entirely, requiring that I use the regular physical click instead, or it's highly, highly unresponsive. I've seen other reports of erratic clicking and the mouse moving on its own after sleeping the laptop, which thankfully mine isn't doing, but I haven't seen anybody reporting this slightly more demure issue.

    In any event, rebooting the machine fixes the problem completely until I sleep it next.

    I'm not 100% convinced that this is an Air issue, however, since I think it affected my 15" MacBook Pro to a lesser degree right after I upgraded that machine to 10.6.5, but I can't be entire certain of that since I no longer have that laptop and rarely used it without an external mouse in the first place.

    Anyone having a similar issue? It's not a dealbreaker, but it would be nice to clear up.
     
  2. shreddog macrumors member

    Joined:
    Feb 3, 2008
    #2
    I have the same problem.

    It is inconsistent though. Sometimes when it won't wake from sleep at all. The only way to get it going is to hold the power button down until it reboots. I've tried to look to see if there the computer is on or if the screen is just dark. I've tried to shine a light through the back but don't see anything so I assume it just won't wake up.

    Sometimes, upon waking, the trackpad doesn't do anything. The pointer won't show up and the only cure, like you said, is to reboot.

    This all very annoying, as I it otherwise a fantastic computer for me and I couldn't be happier. Because it is inconsistent, I am hesitant to take it to the genius bar just yet. Trying to see if it will be fixed with a software update.
     
  3. Hakstern626 macrumors newbie

    Joined:
    Nov 15, 2010
    #3
    i had this same problem yesturday night i was watching a youtube video and i fell asleep and had it on big screen and my MBA went too sleep and i clicked it too wake up and it just stayed black....and had too hold down the power button down too shut it off.
     
  4. mixvio thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    Location:
    Sydney, Australia
    #4
    In my case, I seemed to have fixed it by removing the MagicPrefs program. I probably should have done that in the first place, but I took it out a couple days ago and haven't reinstalled it and so far (fingers crossed) the trackpad problem hasn't come back.

    It's a shame, because I enjoy having the middle mouse button functionality on my Magic Mouse, but the program has given me buggy problems before in the past.

    Do you guys have it installed too?
     
  5. Over Achiever macrumors 68000

    Over Achiever

    Joined:
    Jul 22, 2002
    Location:
    Toledo, OH, formerly Twin Cities, MN
    #5
    Try hitting "esc" to get out of fullscreen mode after you wake up the MBA.
     
  6. Dingleberry1 macrumors newbie

    Joined:
    Nov 30, 2010
    #6
    Hi Mixvio,
    I have just received my 13" Macbook Air and experienced the same issue regarding the tap to click after sleep mode. I contacted Apple Support and they suggested to firstly shut down, then once completely shut down press shift option command and power switch all at the same time for a brief moment (don' hold it down too long). Then switch your machine back on.
    This fixed my problem and now after my machine has gone into sleep mode I can tap the track pad to wake it. Yeahhh Hope this helps.:)
     
  7. tallackn macrumors newbie

    Joined:
    Jun 17, 2011
    #7
    Solution to MacBook Air trackpad click/tap unresponsive after sleep.

    It is a little embarrassing, and I hope I am the only one silly enough to have such a stupid cause for the problem. :confused:

    My Magic Mouse was in my laptop bag, and had somehow been left on or turned on accidentally. It must have been compressed into a click mode, and was in range of my bluetooth on my MBA.

    As a result, operation is normal after initial boot, but if i slept my MBA, when it woke up from sleep, the tap/click primary mouse button on the trackpad was not functional. Only the right click worked.

    Either disabling your bluetooth, or finding your mouse and turning it off, fixes the problem.

    Like I said, a little embarrassing. :eek:
     
  8. neiljr2123 macrumors newbie

    Joined:
    Aug 8, 2011
    #8
    Bluetooth

    OMG, I was doing the same thing leaving my mouse on in my bag.
    How embarrassing lol
     
  9. qwerf123 macrumors regular

    Joined:
    Jul 23, 2011
    Location:
    UK
    #9
    Same here, but there should be a Lion update soon to sort out some of the bugs and hopefully this is one!
     
  10. huschpuscheli macrumors regular

    Joined:
    Jul 28, 2011
    #10
    the tap to click function on my new 2011 air is unresponsive all the time independently from sleep. it's really bothering be. it seems that it just don't recognize the slight taps. i have to tap twice for an action or i have to tap harder (not clicking the trackpad down). but it recognizes swipes all the time independently of the pressure. is somebody experiencing the same? may this be a software or a hardware issue?
     
  11. mixman macrumors member

    Joined:
    Aug 3, 2011
    #11
    Yes. This was one of the reasons I RMA'd my 2011 mba. Taps sometimes worked, sometimes did not -- equal pressure applied. Waiting for a Lion software fix would've been a costly gamble I did not dare take.
     
  12. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #12
    Same problem here. Has anyone submitted a bug report?
     
  13. mixman macrumors member

    Joined:
    Aug 3, 2011
    #13
    Nope. Seems it's done at http://bugreport.apple.com/. Requires Safari to login (after developer agreement), which I do not have at hand at the moment.
     
  14. qwerf123 macrumors regular

    Joined:
    Jul 23, 2011
    Location:
    UK
    #14
    Can't wait for OSX Lion 10.7.1!!!
     
  15. huyazo macrumors newbie

    Joined:
    Aug 21, 2011
    #15
    Same after 10.7.1 update

    Hi

    I experience the same problem with very unreliable tap results, and updating to 10.7.1 didn't resolve the problem.

    I have an iMac, have tried to restart, change some of the settings, disable jitouch and a Firefox gesture add-on I had, but to no avail.

    Very annoying that Apple charge you a zillion for their products, they have full control of HW and SW, and still we have to experience **** like this. I have to look closely every time I tap, since some times I have to tap 2-3-4 times for the app to register (same in many apps so I think this is a OSX problem), but suddenly it registers on the first tap.
     
  16. uming macrumors newbie

    Joined:
    Nov 17, 2011
    Location:
    UAE
    #16
    Try Bootcamp 4.0. My macbook air 13 trackpad has no such issues with it.
     
  17. Oli3000 macrumors regular

    Joined:
    Apr 20, 2009
    #17
    Although slightly different, I often have unresponsive gestures after waking from sleep for a little while! The laptop is working, but no gestures! Very odd!
     

Share This Page