MacBook Air turning off after 6 seconds of no use

Discussion in 'MacBook Air' started by McMatthewL, Dec 17, 2015.

  1. McMatthewL macrumors newbie

    Joined:
    Dec 17, 2015
    #1
    This morning I tried to turn on my mac while it was charging, but it took a few minutes before I actually got it to turn on. After that, the prompt saying 'Are you sure you want to shut down your computer now?' comes up at intervals of around 6 seconds if I don't use the keyboard or trackpad within that time. Either that, or the screen goes to sleep.Every time I switch it back on, it comes up with a message saying something along the lines of 'You shut down your mac because there was a problem'.


    This is obviously very annoying and I've searched for answers, but have only found some people saying it's a hardware issue due to water damage but I have not spilled any liquid on my Mac.

    Obviously if I could get this issue resolved that would be great, but in the meantime I wouldn't mind some ways of making my Mac think that there is a finger resting on the trackpad as that seems to stop it from switching off.

    Any help would be greatly appreciated.
     
  2. canuckRus macrumors 6502

    canuckRus

    Joined:
    May 18, 2014
    #2


    Have you checked your Energy Saver settings in System Preferences?
     
  3. McMatthewL thread starter macrumors newbie

    Joined:
    Dec 17, 2015
    #3
    Yes. 'Put hard disk to sleep when possible' is turned off and everything else is set to go to sleep after an hour of no use.
     
  4. Dadioh macrumors 65816

    Dadioh

    Joined:
    Feb 3, 2010
    Location:
    Canada Eh?
    #4
    Sounds like your power switch is stuck on or mostly on intermittently. Those messages are normal response to when you hold the power switch down. Unfortunately the power switch is aprt of the whole keyboard assembly. You might try powering off the machine and rapidly activate the power switch a bunch of times to see if you could clear out the intermittency issue. Otherwise you are looking at a new keyboard.
     

Share This Page