MacBook Air webpages just won't load?

Discussion in 'macOS' started by Meliam, Jan 2, 2016.

  1. Meliam macrumors newbie

    Joined:
    Jan 2, 2016
    #1
    I have had this problem with my Mid 2013 MacBook Air for a while now. No matter which browser I use, the vast majority of webpages I try to open are forever loading. As in the page is blank and the spinning circle on the tab just keeps spinning. Eventually the page will load after leaving it for 5-10 minutes.

    It's not the Internet connection, because webpages load just fine on all our other devices, and when I download files on my Mac they load as fast as they should. Also I have used my Mac on a friends internet connection and I get the same problem.

    I have been googling around and have tried several things to no avail, such as:

    - updating the OS from Mavricks to El Capitan
    - resetting the DNS
    - changing the DNS to Open DNS
    - got a new modem
    - tried multiple different browsers

    I'm running out of ideas. Can anyone please help? This is infuriating!!

    Thanks
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Check your console logs to see if there are error messages from the browsers or network
     
  3. IHelpId10t5 macrumors 6502

    Joined:
    Nov 28, 2014
    #3
    Do you have any antivirus or security software, or VPN software installed on the Mac?
     
  4. IHelpId10t5 macrumors 6502

    Joined:
    Nov 28, 2014
    #4
    Try opening "System Preferences" > "Network" > "Location:" > "Edit Locations..." > Click the "+" > enter a name like "New" > click "Done" > then select the "New" network from the "Location:" list.
     
  5. Meliam thread starter macrumors newbie

    Joined:
    Jan 2, 2016
    #5
    I tried to load a webpage and watched the messages come up on console from when i opened the page until it loaded. I am not sure what they mean. I've attached a screenshot to this message.


    Yeah I have Avast installed, and also have Hola but I think that is only a Chrome extension.

    I tried this but it didn't work :(
     

    Attached Files:

  6. satcomer, Jan 8, 2016
    Last edited: Jan 16, 2016

    satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #6
    According to your logs post it is Avast that is screwing up. Dump it on a Mac and if your are still paranoid use Malwarebytes.
     
  7. Meliam thread starter macrumors newbie

    Joined:
    Jan 2, 2016
    #7
    Thanks satcomer! I disabled Avast web shield and everything seems to be working normally now :)
     

Share This Page