Macbook airport extreme card/not connecting to internet

Discussion in 'MacBook' started by kdub, Feb 24, 2009.

  1. kdub macrumors newbie

    Joined:
    Feb 12, 2009
    #1
    I just bought my first Mac from ebay i'm a new user and don't know much about macs, I was using my ethernet to surf the web until my belking router comes in. So this is what I have done so far my desktop is wired to the router running XP the connection is fine and my setup is a WPA, my macbook is running 10.5.6 Lepord my router says the MB is connected to the router but I'm unable to connect to the internet. TCP/IP is set to DHCP my airport says status on, and that it has a self-assigned IP address and may not be able to connect to the internet I've already have my MB set to share web, internet, files & printers on my network. Is there something i missed or i'm doing wrong I called belking and got no problems with the router we used many setup changes and I ran a hardware test on my MB and no problems were found.:confused:
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Turn off web sharing. That setting is used for when you want your MB to be a "router" or to connect another computer to it.

    Also, did you enter your WPA key correctly?
     
  3. kdub thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    #3
    Still not working


    I just tryed it and my WPA key it logs on to my network when i turn on my MB I even tried turning off/on my airport card and got nothing.:confused::confused:
     
  4. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #4
    Did you try turning off web sharing?
     
  5. harry454 macrumors 6502

    Joined:
    Sep 13, 2007
    #5
    try reseting pram and nvram,
    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.
     
  6. chucktown macrumors newbie

    Joined:
    Feb 24, 2009
    #6
    I'm having the same problem, but only when i try to get on my schools wireless network, airport says i have a self assigned ip address using airport or ethernet over their network...the apple support page says that pram does not contain network settings on OS X
     
  7. kdub thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    #7
    I'm still getting the same results


    I took out web sharing as well I think I'll find a apple store, Thanks for your help everyone.:)
     
  8. kdub thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    #8
    I got to work now WooHoooooooo!!!!!!

    I don't know if this will work for all routers but here's my setup and what I did, I have the Belkin N Wireless Router #F5D8233-4 and after all the configuring I decided to push the reset button for 10 sec to erase everything I did. Then I only did my wireless setup from the address bar I did'nt use the software cd this time, anyway I used the WPA/WPA2 as before, turned on my airport and nothing I clicked network diagnosis and it come on before i could finish the scan I'm writing this from my macbook now. Hope this helps anyone I check back to see if anyone has any questions :)
     
  9. tdevers macrumors regular

    Joined:
    Apr 21, 2008
    #9
    I had a similar problem with all routers. Apple ended up replacing the airport card and all is well.
     
  10. NateDMB macrumors regular

    NateDMB

    Joined:
    Jan 25, 2008
    #10
    I had the same problem (although I have a D-link). after days of trying different things, the problem was solved by turning off "Wi-Fi protected setup" off. I stopped my airport from maintaining any connection. Not sure if that helps you but it might help someone.
     

Share This Page