macbook airport wireless problem.

Discussion in 'MacBook Pro' started by lilodxd, Dec 28, 2007.

  1. lilodxd macrumors newbie

    Joined:
    Sep 3, 2007
    #1
    my macbook has been working fine up until yesterday when for no reason, the wireless stopped working. in airport, it shows that i am connected to a network and the strength is even high. but when i open firefox, safari, etc, it says that i am not connected to the internet. if it matters, i installed the automatic apple updates a few days ago and that may be related.

    i've already tried looking on apple's website for support and even resetting the airport preferences.plist but that didn't work. any help would be appreciated, thanks.
     
  2. 119576 Guest

    119576

    Joined:
    Aug 6, 2007
    #2
    It could be a problem with your router. Have you tried other computers on the network, or accessed the internet via other routers?
     
  3. skyrider007 macrumors 65816

    skyrider007

    Joined:
    Aug 5, 2007
    Location:
    Bangkok
    #4
    I believe this is a Leopard issue since the recent security update. Happens to me as well, you're not the only one out there.
     
  4. iBecks macrumors 6502

    Joined:
    Nov 24, 2006
    Location:
    Nottingham, UK
    #5
    I had the problem and resolved it by going changing from 802.11n to 802.11g on the router.

    I'm not sure if that will help you, but if you have an 802.11n rated router you could give it a try.

    Of course, this is a workaround for me until Apple fix the issue.
     
  5. lilodxd thread starter macrumors newbie

    Joined:
    Sep 3, 2007
    #6
    hey, thanks for the responses. i'm running 10.4, not leopard. as for the router, i'm actually "borrowing" the connection from my neighbor. perhaps it is a problem with his router and not with my laptop?
     
  6. ZenErik macrumors 6502

    Joined:
    Dec 22, 2007
    Location:
    Massachusetts
    #7
    I am experiencing my wireless connection randomly dropping too. I'm using a Linksys WRT54GS. I've never had problems in the past with my other computers, and I didn't notice a problem with this one until I upgraded to Leopard. It just randomly drops every once in a while. Maybe 4 - 6 times per day.
     
  7. mcvaughan macrumors 6502

    Joined:
    Aug 9, 2007
    Location:
    Houston, TX
    #8
    I bought an Apple Extreme Base Station to replace my Linksys and my issue was resolved. The AEBS has better range too, in my experience.
     
  8. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #9
    a beingn experiment

    So I have managed to maintain a stable connection by going into the router's settings and selecting one channel instead of automatic and selecting mixed mode instead of Wireless G. It has been stable and connects after sleep or any shutdowns.
     
  9. ZenErik macrumors 6502

    Joined:
    Dec 22, 2007
    Location:
    Massachusetts
    #10
    I changed some settings on my router including changing the password to WPA2 Personal instead of WEP. Everything has been good since.
     
  10. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #11
    keychain...

    Ted400 reports the following: "So... a week later and still running. It looks like this problem is directly related to the permissions listed in the keychain as stated earlier. I was able to speak with a Apple Product Specialist today (after being on hold for an hour), and it seems that he agreed that that was the problem. He stated that when you upgrade you may have been asked to accept that ol' pop up box regarding the keychain access. If at any point you did not choose to accept ALL changes it could have changed the permissions on the keychain item for your network, thus causing the problem. I hope this solves the problem...we will have to wait and see."
    I did recently deleted all the keychains, keychainprefs.plist and in the keychain app, whenever you redo your settings go back and highlight the key for your wireless network and double click and under the Access Tab select the "allow all apps to access this key" or make sure you see the system prefs icon and an airport file icon there.
     

    Attached Files:

Share This Page