Macbook Aluminum 13" not working

Discussion in 'MacBook' started by HarryWorksInc, May 27, 2011.

  1. HarryWorksInc macrumors regular

    Joined:
    Feb 21, 2010
    #1
    Hey, so my laptop was in a flood (while on) about a month ago so I ordered some parts to fix it up, motherboard, hard drive, dc in board, and some screws I had lost. I replaced everything, I turned it on, got the dong, waited a couple of seconds then a folder with a question mark in it popped up, I know this means the computer isn't recognizing the heard drive. However I know the drive is good because I hooked it up to another computer and set up snow leopard on it. I have tried everything I can think of. I have tried holding option while booting but a mouse comes up and then there are no drives to select. I have poured a nice amount of money into this and really would like it to work, so any suggestions would be appreciated.

    I have also tried flashing the PRAM.
     
  2. MultiFinder17 macrumors 68000

    MultiFinder17

    Joined:
    Jan 8, 2008
    Location:
    Tampa, Florida
    #2
    Have you tried putting an OS X disk in the optical drive and booting off that?
     
  3. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #3
    Boot from the OS disk, install, and it should work.
     
  4. OneMike macrumors 601

    OneMike

    Joined:
    Oct 19, 2005
    #4
    Ok I'm assuming you installed snow leopard on one computer, then tried to move the hard drive to another?

    I'd first put the snow leopard disc in the computer that doesn't load. Hold down c to get to disc utility, then see if the HD is being recognized.

    As you replaced a lot of things it's possible maybe even the hard drive ribbon is not connected or something. I'd go into disk utility first and see what it shows.
     

Share This Page