Macbook and External VGA LG monitor problem

Discussion in 'MacBook' started by darkmeton, Feb 5, 2009.

  1. darkmeton macrumors member

    Joined:
    Mar 20, 2008
    #1
    Just bought a new 22' LG monitor and I have the Mini DisplayPort to VGA. When I connect my monitor to my MacBook all is OK until I try to chose the 1680x1050 which is the LG's prefered resolution. When I chose it, my monitor turns to black, then after a while it shows the picture for a second, then black again.. Is this a 9400m fault, or the VGA adapter fault?
    If I try a MiniDisplay port to DVI, will it work in 1680 x 1050?
    All the other resolutions are shown ok..
     
  2. andrewag macrumors 6502

    Joined:
    Jan 11, 2005
    Location:
    Australia
  3. pellets007 macrumors 6502a

    pellets007

    Joined:
    Jan 28, 2009
    Location:
    New York
    #3
    I have a 1080p monitor, and unless I have to, I would always go with analog. The reason being that DVI isn't compliant with most projectors. I have an Intel 945 on my laptop, which shares 128mb, and I get lines across my monitor. I suppose that's because of the combination of VGA and a divided 64mb of RAM.:eek:

    Hope it just turns out to be a defect, I really was hoping I wouldn't have to shell out another $30 for another cable.:rolleyes:
     
  4. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #4
    Sorry to hear about your problem, but it is all over the Apple forums and has been ever since the new MB/MBP line came out:

    http://discussions.apple.com/thread.jspa?threadID=1756755&tstart=15

    Unfortunately this affects both VGA and DVI connections, including Apple's own ACD (I don't know if the new 24" is affected). As usual, Apple has never publicly acknowledged the issue, but they did recently come out with a fix that it sounds like you have, and it just made the problem worse (much worse). Most people report that before the patch their display would blink off for a second or so every once in a while but come right back on; now after the patch it blinks on for a seconds but is mostly black. I think Apple pulled the patch after a day or so.
     
  5. darkmeton thread starter macrumors member

    Joined:
    Mar 20, 2008
    #5
    thanks for your replies. Guess I should have checked first before I go and buy a new monitor... :( So there is nothing to do but wait for apple to fix the problem..

    P.S. My monitor has support for HDCP so I don't think that HDCP is blocking the signal to full 1050..
     
  6. darkmeton thread starter macrumors member

    Joined:
    Mar 20, 2008
    #6
    YES! I've found the solution in apple forums! Worked for me!! So here it is from member " gingy22"


    1. Throw a tantrum (most people have already completed this step...) maybe call Apple and let them know their update is no good. If you do not talk to a specialist there is no chance engineering will find out you as well are having the issue.

    2. Install SwitchResX from either of the first two links on this page (hopefully the site doesn't go over bandwidth from this) http://www.madrau.com/html/SRX/DL.shtml

    3. Launch SwitchResX with your external display connected in Extended Desktop Mode. (Should be located in your system preferences from the blue Apple)

    4. Select your display in the drop down menu at the top of the program

    5. Select the Custom tab

    6. Hit the plus in the lower left

    7. A confusing screen at this point pops up. Don't change anything except!... Active which is the native resolution you put in there. As well put under scan rate 60 in both fields. In other words make sure your mac does not use anything except 60Hz.

    8. Click OK to dismiss that screen and hit apply and authorize with your password.

    9. Restart your computer or the setting will not appear in your system preferences.

    10. Once again make sure your computer is in extended desktop mode once restarted

    11. Launch system preferences from the Apple and select displays this time

    12. On the macbook display hit the gather windows button in the display tab

    13. Your external display should have a window on the screen of your macbook now so select your resolution you put in SwitchResX and 60Hz should now be an option in the Refresh Rate section as we added it and restarted.

    14. Jump for joy if it worked!
    
The follow is for clamshell mode users only like myself 



    15. Put your computer to sleep



    16. Wake your computer from sleep in clamshell mode and if your lucky it won't be flashing as it seems to be a glitch as it's now broadcasting 60Hz but the setting goes back to 59Hz because it thinks it's a different display now or something.



    17. Go into system preferences displays again and change the Refresh Rate back to 60Hz because if you don't and you put your computer to sleep the flashing will come back and revert to 59Hz won't woken from sleep if you don't do these steps.

I hope this helps as I tried to be as detailed as possible and I hope this works for all.
     

Share This Page