MAcBook and HP Laserjet 2100 printing problem

Discussion in 'Mac Basics and Help' started by uodbloke, Jan 25, 2007.

  1. uodbloke macrumors newbie

    Aug 30, 2006
    I am not sure if I am submitting this to the right forum but I hope someone can help. I have a problem with printing from my MacBook. I have downloaded the latest driver from the HP site and installed it etc. with the help of Apple Technical Support. The printer is connected to my MacBook with an IEEE 1284 (Old Parallel Printer connection) to USB lead. The issue is that when I try to print it prints out a page with an error such as

    %RBINumCopies: 1
    %% Pages: (atend)
    % APL_DSCEncoding: UTF8

    then a number of blank pages then a final page with a variety of code.
    I have tried clearing the print cues on the computer and powering down the printer to clear the memory. I have also uninstalled and reinstalled the printer but the same error still comes up. Any help or suggestions would be gratefully received.

    Thanks in advance.
  2. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida
    Is it a 2100m? It looks like it's trying to print in Postcript and you are sending PCL maybe (or vice-versa). Do you have the printer set to auto-switch languages? You should be able to check the set-up printout for that.

    If the printer has an "M" in the name, it is a postscript printer. I'm printing fine to a 4000, but we have it on our network. I'm really trying to dig deep in the brain here on this, one - it's been awhile :D
  3. uodbloke thread starter macrumors newbie

    Aug 30, 2006
    Thanks for taking the time to reply. It is a 2100 only, no letters. Someone else has suggested that I may require a Post Script module for the printer so I am trying to track one of those down.


Share This Page