Macbook and Netgear DG834G - Confusing!?

Discussion in 'MacBook Pro' started by Robart, Feb 25, 2007.

  1. Robart macrumors newbie

    Feb 25, 2007
    Hi All,

    New to the forums, I've seen some great advice so i wondered if anyone could help me. I've seen this probelm on a previous thread but hoped someone would have the definitive solution. Here goes...

    I have two PC laptops working wirelessly with the Router. They have both been added to the Access list and I have WEP enabled. I have added my Macbook to the access list. When asked for the WEP password on the Macbook I typed a 0x in front of the password and it worked. So far so good.

    However this morning, it doesn't work. I've followed the exact same procedure as I didn't save the password in my keychain. The only difference between the connection working and not working is one of the PC Laptops is turned on and connected. Does anyone know the solution to this? It seems ridiculous that I can't be connected to the router if one of the PC laptops is too!

    Any help greatly appreciated!
  2. zali0n macrumors regular

    Nov 23, 2006
    Kent, UK
    Do you have any additional type of security of the router? i.e MAC only access list or something?

    It might be that you may just need to reboot the router or something. Is this the first time this has happened?
  3. Robart thread starter macrumors newbie

    Feb 25, 2007
    Access control is checked, so the router will only allow MAC addresses which have been added to the list. I've added my Macbooks MAC address. I was able to connect yesterday, I thought it might be becasue the other PC laptops were on at the time, I've turned them off and still have the same problem.
  4. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I don't know how to do this part in Windows without looking at a Windows computer, so I can explain the concept and how to do it on a Mac.

    You should make sure on each of your computers that it is using DHCP to allow the router to assign it an IP address and is not forcing itself on a particular IP address instead. If a computer tries to get an IP address that is already being used by another computer, or if an existing computer has taken by force an IP address that the router tries to assign to a new computer, the second computer connecting will fail to acquire a connection.

    On the Mac, the way you do this is: Sys Prefs -> Network -> Airport -> TCP/IP -> Configure IPv4 via... Using DHCP.
  5. jm12345 macrumors newbie

    Feb 21, 2007
    how do you like your netgear? Its funny that you said that cause my friend with his G4 was having problems with our netgear and still is.
  6. Robart thread starter macrumors newbie

    Feb 25, 2007
    Thanks for the help, much appreciated. All appears fine now. The Netgear router itself is great. I have however discovered a problem. If my flat mate is downloading a large file on to his laptop I cannot connect to the router with my Macbook. As soon as he stops I have to reset the router and everything is fine! If you have any ideas at all about what is going on here I'd be eternally grateful!
  7. Robart thread starter macrumors newbie

    Feb 25, 2007
    Did your friend with the G4 try putting a $ in front of the WEP key? My friend had the same problem and this solved it.
  8. Piarco macrumors 68030


    Jun 24, 2004
    So that's what I needed to do to get the WEP working! I had a DG834G but had to leave it unsecured (but hidden for what that's worth) as I could never get the password to take - now I know why!
    Shame I sold it on, but as I'm about to get the DG834N its a tip worth knowing incase it needs to be entered like that again. Gotta love MR for the unexpected tips! :D
  9. M@lew macrumors 68000


    Nov 18, 2006
    Melbourne, Australia
    Yeah I have this router too and when I first got my Macbook it was really confusing why my WEP key wasn't working.

    I have no idea why you have to put a $ sign's just weird.
  10. Pavsta macrumors newbie

    Jun 29, 2007
    THANK YOU (shouting deliberate) I've been trying to solve this for days. It works! (I have to stay with WEP as I use a Netgear ME-101 bridge for my xbox360).

Share This Page