Macbook and Xbox 360

Discussion in 'macOS' started by stellarceltic, Nov 28, 2007.

  1. stellarceltic macrumors member

    Joined:
    Oct 25, 2007
    #1
    Just yesterday I found out that I could connect my 360 to my MacBook and piggyback its wireless internet connection. The only problem is that my NAT setting on the 360 is now Moderate. When it was hard wired to the router, it was Open.

    I know I can do port forwarding on the router to get it back to Open, but that's where I hit a snag. I have a Linksys WRT54G router. When you want to do port forwarding, the IP address of the computer/360 has to start with 192.168.1.* The only problem is that the 360's IP address that I had to give it is 192.168.2.2

    I used the tutorial found here: http://www.ofzenandcomputing.com/zanswers/358

    Does anyone know what settings I can alter to get this done? The problem stems from Step 1. My "inet" is 192.168.2.1. He says to just add one for the 360's address. How can I change the "inet" to start with 192.168.1.* ?
     
  2. stellarceltic thread starter macrumors member

    Joined:
    Oct 25, 2007
    #2
    Here is a pic from Terminal.

    I'm not exactly sure what "inet" is, but I know it's the problem.

    If I can somehow edit inet to start with 192.168.1.*, I can do the same with the Xbox, and then do the port forwarding.

    However, as long as my inet starts with 192.168.2.*, then the Xbox must also, and I'm SOL.
     

    Attached Files:

  3. stellarceltic thread starter macrumors member

    Joined:
    Oct 25, 2007
    #3
    :( sad face bump :(

    Does anyone even know what "inet" means?

    I thought it might be the IP address of the Macbook, but I don't think it is.
     

    Attached Files:

  4. stellarceltic thread starter macrumors member

    Joined:
    Oct 25, 2007
  5. Krevnik macrumors 68030

    Krevnik

    Joined:
    Sep 8, 2003
    #5
    Use the internet sharing feature in the Sharing preferences panel, it should let you bridge the ethernet into your wireless internet.

    What you are seeing isn't /wrong/, and actually looks pretty good, but setup internet sharing how Leopard recommends and it should be good to go.

    EDIT:

    I misread the problem. The problem you are seeing has no good solution, really. By sharing the wireless with your laptop, you are effectively putting the laptop as a router between the 360 and the internet. Unless you can find a way to port-forward to your laptop, and then port-forward THAT to the 360, you will need to keep the 360 connected directly to the Linksys using ethernet or a wireless adapter you can purchase.
     
  6. stellarceltic thread starter macrumors member

    Joined:
    Oct 25, 2007
    #6
    I had to enable Internet Sharing to get it to work at all. It works now, but the NAT settings need to be adjusted somehow.
     

Share This Page