iPhone 8(+) MacBook appears in "speaker" during calls

phonohead

macrumors newbie
Original poster
Sep 9, 2019
6
1
Greetings!

This has been bothering me for a long time now. I've been searching the web up and down, east to west, but still no solution to this issue.

When I make a phone call and want to use the loudspeaker, I can see a list of two MacBook Pros. I have not activated "call on other devices" in the settings on my phone or on my MacBook. Why does these MacBooks appear?

The Macbook is mine, indeed, but I've not enabled it for phone calls.

Any help is very appreciated!

Screenshot is attached!
 

Attachments

Kmart9419

macrumors 6502
May 4, 2011
269
325
Have the same problem with all my apple tvs showing up. No idea how to get rid of it.
 

phonohead

macrumors newbie
Original poster
Sep 9, 2019
6
1
SOLVED: You log in to Apple-id, either via your browser or your phone, and remove the MacBook/device appearing under the speaker option. This fixed it for me. The downside is that you need to sign in again from said MacBook/device. A tiny hassle, but well worth the fix!
 

chabig

macrumors 603
Sep 6, 2002
6,309
3,510
I have not activated "call on other devices" in the settings on my phone or on my MacBook. Why does these MacBooks appear?
This has nothing to do with wifi calling the MacBooks. It just means that you can route audio to them using AirPlay.
 

phonohead

macrumors newbie
Original poster
Sep 9, 2019
6
1
Well, it removed them from the list anyway. And that's regardless of AirPlay being on or off, it seems?

Edit: I misinterpreted your message. Disregard my reply.