MacBook Audio problem

Discussion in 'MacBook' started by eredmond, Jan 8, 2010.

  1. eredmond macrumors newbie

    Joined:
    Jan 8, 2010
    #1
    The audio on my 2006 MacBook has recently stopped working. I thought the internal speakers might have blown, but the audio doesn't work even if I use headphones or external speakers through the headphone jack.
    When I use the volume control buttons, everything looks normal - I don't get that symbol that it seems most people do when their audio isn't working. The levels will go up and down but without the sound usually associated with the volume control.
    I checked out the sound option in System Preferences, and everything is normal. I'm running OS X version 10.4.11. I've tried rebooting and nothing changes. All the other threads I've seen seem to have that symbol when using the volume control, or something is different under System Preferences, but everything is normal.
    Any ideas??
    Thanks so much!
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Is there a red light coming out of the headphone jack? If so, the jack is stuck in optical-out mode. You'll need to fiddle with it with either a mini-TOSlink plug, a headphone plug or a toothpick and get the switch to flip back from the optical out mode.
     
  3. rhythm12345 macrumors newbie

    Joined:
    Jan 7, 2010
    #3
    audio problem

    It can be possible that there is a red light coming out of the headphone jack, that might be the main source of the problem.
     
  4. eredmond thread starter macrumors newbie

    Joined:
    Jan 8, 2010
    #4
    there's no red light; I looked in there with a flashlight, everything looks ok (and by ok I mean I know absolutely nothing about what it should look like, but everything's symmetrical and there doesn't appear to be something wrong).

    :confused:
     
  5. ptsube macrumors 6502

    Joined:
    Oct 12, 2008
    #5
    Look at it in the dark. If you use a flashlight you might not be able to see the optical light. Make sure your computer is on and you have something playing.
     
  6. Kevin07 macrumors newbie

    Kevin07

    Joined:
    Jan 9, 2010
    Location:
    Perth, Western Australia
    #6
    Have you tried to run diagnostic tests. Mac OS X Leopard has a diagnostic scan included with the DVD/CD that came along in the OS X package. If it renders failed then bring it into a local Apple Store.
     

Share This Page