Macbook Battery not charging since Lion upgrade

Discussion in 'Mac OS X Lion (10.7)' started by mojo30, Jul 22, 2011.

  1. mojo30 macrumors newbie

    Joined:
    Jul 22, 2011
    Location:
    Minnesota, USA
    #1
    Anyone finding that their battery doesn't charge now that they've upgraded to OSX Lion? When I rebooted my MacBook Pro after the upgrade, the battery doesn't charge any more.

    Any suggestions?
     
  2. TheTraveller9 macrumors newbie

    Joined:
    Jul 23, 2011
    Location:
    Madrid, Spain (E.U.)
    #2
    MacBook battery not charging

    I have a MacBook 13" and my battery doesn't charge since last night. I installed Lion yesterday, and the battery was charging correctly, but since this morning it doesn't charge at all and I'm afraid it'll lose all its power soon.

    Did Apple or anyone find any solution to this issue??

    I've tried resetting SMC, removing the battery, clicking power button 5 seconds and all that stuff...

    Any idea?

    Thanks in advance.
     
  3. NVieira macrumors newbie

    Joined:
    Jul 23, 2011
    #3
    Macbook Battery not charging since Lion upgrade

    I've been experiencing the same problem after installing Lion, but after a few minutes the battery started recharging again...pretty strange.
     
  4. TheTraveller9 macrumors newbie

    Joined:
    Jul 23, 2011
    Location:
    Madrid, Spain (E.U.)
    #4
    Battery not charging

    I'm trying not to use my MacBook in order to have enough battery life to install any patch or whatever necessary to solve my problem.
    I've tried everything and no results. At the beginning I thought it could be simply the MagSafe AC adaptor, but then I 'googled' my issue and I found I was not the only one with the same problem.

    Still waiting for some light at the end of the tunnel :p
     
  5. Mografi macrumors newbie

    Joined:
    Oct 16, 2008
    #5
    I'm having the same problem!

    2.4ghz i5 15" Macbook Pro 2010 model.

    Upgraded to Lion yesterday, and now the computer is not using the charger at all (no lights). Going to be dead in about 40 mins. I've NEVER had this problem, EVER on this laptop, or the previous one...so it definitely must be something with Lion...very sad, cos I generally like the stuff Lion has added.

    I tried resetting the SMC and the charge light came on for a minute, but as soon as Lion was booted again it stopped working.

    ...very strange and unfortunate bug.....not sure how this is in a retail OS release.
     
  6. TheTraveller9 macrumors newbie

    Joined:
    Jul 23, 2011
    Location:
    Madrid, Spain (E.U.)
    #6
    How to fix?

    What I'm worried about most is how Apple will do to fix this issue. Why? Just simply because our batteries will die outta power one day or another, and then, how come will we be able to install a patch or whatever? Will Apple provide us with some hardware or what?

    I'm really disappointed with Lion. New functions are nice but they aren't enough for considering it a 'new' OS. I'm still running Leopard: 10.5, 10.6 and now 10.7.

    Does Apple really think that I'm gonna install it in my MacPro after having these problems with MacBook??? Guys, I'll only lose one computer...

    Still waiting for a solution... and our batteries go by...
     
  7. Hunter45S macrumors newbie

    Joined:
    Jul 26, 2011
    #7
    solution to LION battery charge issue

    I found this solution in an old pot from 2010 and tried it and it worked Quote:

    I had the same problem as everyone else here. I installed a brand new battery (on my MacBook Pro 2.6 GHz Intel Core 2 Duo) because my old one was just plain worn out and would only hold a charge for about 30 mins. When I installed the new battery, it stopped charging at 45% and stayed there. I tried all of the "pre-SMC reset" options suggested by Apple with no luck, so I repaired Disk Permissions and reset the SMC. The first time around it didn't work. When I plugged the battery and charger back in, the battery was still at 45% and not charging.

    So I reset the SMC again, but this time paying attention to the order things were done, and it worked. The battery is now charging. Here's what I did:

    I unplugged the power supply, removed the battery, and then held the power button down for five seconds. Then I plugged the power cord back in FIRST, so that the LED lit bright green (it was a dim green when the battery was installed first). Next I installed the battery. After a few seconds, the LED on the power plug turned dim green again, but when I rebooted the computer, the battery immediately began charging.

    I have no idea if doing things in this particular order really worked or if it was just a fluke, but I thought I'd share it here in case it's useful for anyone else.
     
  8. TheTraveller9 macrumors newbie

    Joined:
    Jul 23, 2011
    Location:
    Madrid, Spain (E.U.)
    #8
    I found that way of resetting SMC on Internet and already tested it, but no results in my case.
    Congratulations to those of you who have solved it that way, but I keep on insisting: there's a big bug concerning power and batteries in Lion that must be solved by Apple. Several discussions have been opened in Apple Communities about this issue.
    Good luck.
     
  9. ChrislAtkinson macrumors newbie

    Joined:
    Jun 28, 2009
    #9
    Battery Issues Here

    Since my upgrade to lion my MBP battery is not holding a charge and is reporting the battery is needing serviced. What the heck! Prior to Lion I could go hours upon hours without needing a charge! Their is a serious bug here. The SMC reset did not work for me and Apple Care suggested I do a clean install and see if the battery really needs serviced, no help! Come on Apple, fix this!
     
  10. TheTraveller9, Aug 8, 2011
    Last edited: Aug 8, 2011

    TheTraveller9 macrumors newbie

    Joined:
    Jul 23, 2011
    Location:
    Madrid, Spain (E.U.)
    #10
    still silence...

    Two weeks and Apple still keeps silence... no press release, no support note, no discussion reply...

    This issue stinks more every day, doesn't it, dudes?

    I've just called Apple Care and I've been told to take my MB to an authorized center, this is to say: Apple won't admit this error as theirs, so they'll treat our computers as separated cases. Typical...

    Of course, I'll insist in making Apple guarantee (because I've just bought a """new""" operating system, this is a product) pay everything. I swear Apple won't dare make me pay anything MORE (I think that 23,99€ is enough for this face-cleaning operating system).

    I'll tell you, guys...
     
  11. ralphociravla macrumors newbie

    Joined:
    Aug 9, 2011
    #11
    i also had the macbook not charging issue a while ago...
    its been a week already since instaled Lion os on my macbook pro 13", ever since i installed it. i got no issue not until now. when i turned on my MB it was still about 40% on battery, and when it was already about 15% i decided to plug its charger. but then to my surprise, my MB wasn't charging. i tried unplugging the charger then putting it back again, still it won't charge. So i decided to shut it down. then Plug the charger, luckily it charge. then i proceeded on turning it on. Now my MB is already charging. hope this won't happen again, and apple will fix this issues. Is there an update already for Lion 10.7 ????
     
  12. stevetmq macrumors newbie

    Joined:
    Sep 15, 2009
    #12
    Same sort of problem

    I had a good battery (120 charge cycles) when I installed Snow Lepard 10.6.0. Between then and the upgrade sequence to 10.6.8 (over 2 days) My battery has stoped working all to giver with some strange reading from the system information app:

    This has happend to two batterys once in the UK where I could get to an Apple store when I first installed Snow Leapard and the updates where done as Apple relest them. The battery was replaced by the Apple Store and the replacement is now shot after a reinstall of Snow Leopard and combined update before the update the Battery reported fine and lasted 3 hours after update it's bricked. I am now in Greece and getting there is no places like Apple Store over hear (yes there is iSquare in athens but thay sead thay would have to send the laptop somewhere)

    Any idears?

    Model Information:
    Manufacturer: Sony
    Device name: ASMB012
    Pack Lot Code: 0001
    PCB Lot Code: 0000
    Firmware Version: 0110
    Hardware Revision: 0500
    Cell Revision: 0303
    Charge Information:
    Charge remaining (mAh): 0
    Fully charged: Yes
    Charging: No
    Full charge capacity (mAh): 0
    Health Information:
    Cycle count: 122
    Condition: Replace Now
    Battery Installed: Yes
    Amperage (mA): 61
    Voltage (mV): 3671
     
  13. Avatar74 macrumors 65816

    Avatar74

    Joined:
    Feb 5, 2007
    #13
    If your symptoms include constantly running fan, the charger cord light is out, the backlight on your keyboard is dead, and/or a battery indicator that shows "x" with the message "battery not available", this appears to be the answer:

    http://support.apple.com/kb/ht3964

    Reset the SMC. I did this and everything is back to normal. The battery now shows 97% charged, the fans aren't running, the keyboard backlight works, etc.
     
  14. blackburn macrumors 6502a

    blackburn

    Joined:
    Feb 16, 2010
    Location:
    Where Judas lost it's boots.
    #14
    You can also reset the pram 4! times in order to really reset it. I've had issues with lion and a normal pram reset wouldn't work. Since my macbook is going to repairs *again* I can't be much help.
     
  15. prophetgeek33 macrumors newbie

    Joined:
    Aug 17, 2011
    #15
    Solved

    turn off computer

    hold+option+command+power button at the same time for 10sec

    let go laptop should power on plug your cord up and wait for about 5-10sec and battery will charge
     
  16. modelbehaviour macrumors 6502

    Joined:
    Sep 23, 2007
    Location:
    UK
    #16
    I'm having the same problem, I've tried the fixes here but it still doesn't work. I've installed yesterday's update and that doesn't fix it either.
     
  17. amimed macrumors newbie

    Joined:
    Jul 25, 2011
    #17
    hello guyz i'm having a huge problem here
    i'm working with my macbook 13" 2 hours ago and suddenly watts says that the cord power is unplugged , and the green led is turned off. i dont know whats the problem , is it the charger or something else , notice that i've upgraded to 10.7.1 yesterday.

    help me guyz please , i dont know what to do
     
  18. jacksonwong macrumors newbie

    Joined:
    Dec 3, 2011
    Location:
    Sydney, Australia
    #18
    Solved

    Thanks prophetgeek33, this solved my battery charging issue! :)
     
  19. RcklssWthYrLv macrumors newbie

    Joined:
    Dec 11, 2011
    #19
    Another solution.

    Hey everyone,

    Registered because this is the first result you get when you google "Mac not charging". I tried the various solutions but what ended up working was to simply remove the fuse and put it back in again. I don't know how or why this fixed the problem but it worked.
     
  20. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #20
    There is no fuse. What on earth are you talking about?
    No, it didn't. Perhaps the powering off and on helped, but that key combination has nothing to do with battery/power/charging issues. Only resetting the SMC addresses such issues.

    This should answer most, if not all, of your battery questions:
     

Share This Page