MacBook battery problem (charging very slowly)

Discussion in 'MacBook' started by Astral Cars, Feb 22, 2010.

  1. Astral Cars macrumors regular

    Joined:
    May 11, 2005
    Location:
    St. Paul
    #1
    I picked up a black MacBook on eBay recently and it seems it came with a new battery. The battery is not an Apple one and oddly the exposed surface of it is more rubbery than the rest of the MacBook. I didn't expect much and my initial impression was that it lasted a pretty good while, but seemed to discharge while sleeping a little faster than expected.

    Anyway, the problem has become that while it's plugged in the menubar battery info flashes (Not Charging) every once and awhile as if it loses its connection. At first this was infrequent and didn't seem to matter. Now it happens every 7 or 8 seconds and leads to the battery charging fantastically slow. It's at 72% and iStat says it needs another 23 hours to be fully charged (it said 10 hours about 15 minutes ago).

    Any idea what's going on or how to fix it?


    Battery Information:

    Model Information:
    Manufacturer: DP
    Device name: ASMB013
    Pack Lot Code: 0001
    PCB Lot Code: 0021
    Firmware Version: 0010
    Hardware Revision: 001f
    Cell Revision: 7a3e
    Charge Information:
    Charge remaining (mAh): 3741
    Fully charged: No
    Charging: Yes
    Full charge capacity (mAh): 5186
    Health Information:
    Cycle count: 21
    Condition: Normal
    Battery Installed: Yes
    Amperage (mA): 123
    Voltage (mV): 12261
     
  2. Astral Cars thread starter macrumors regular

    Joined:
    May 11, 2005
    Location:
    St. Paul
    #2
    Hmm, it may have been mostly outlet related. I just switched it to the other socket on the same outlet and now I'm up to 75% and it says 1 hour 50 minutes remaining. That still seems like a lot, but at least it's not 23 hours. Was the other plug likely just giving me a sloppy supply?
     
  3. darkmoon12198 macrumors newbie

    Joined:
    Jan 9, 2010
    #3
    No idea why it's doing that... Maybe the charger port is dirty. Try cleaning it with rubbing alcohol. Also, that's what you get for buying off of eBay... You should always ask EVERYTHING before buying from there.
     
  4. darkmoon12198 macrumors newbie

    Joined:
    Jan 9, 2010
    #4
    Oh, sorry, I was typing when you posted in my before post.. Anyways, that could be it, most likely. Or, if it happens in more outlets, it might be a defect in your charger.
     

Share This Page