Macbook Battery "x" Problem

Discussion in 'MacBook' started by RBrade, Mar 5, 2010.

  1. RBrade macrumors newbie

    Apr 16, 2008
    Hello all. I have been having trouble with the battery on my white late 2008 macbook A1181. Coconutbattery says my battery is great (read: amazing) at 571 cycles and 96%. No complaints there.

    The problem is that whenever the computer is unplugged, is dies suddenly. When I turn it back on, it has a big X over the battery and it will not stay on unless it is plugged in. The computer is aware the battery is there, I can get info on it from the "about this mac" section, but it won't stay on unless its plugged in. The battery condition is showing as Normal.

    This problem occurred early in my macbook's life and then spontaneously fixed itself. Now it is back. From the reading i have been doing, a new battery does not fix this. The general feeling is that its a logic board issue. I'm glad i did some reading on the problem, as i was going to buy a new macbook soon. If this is an Apple problem, i don't think i will be spending $1500 on a "mobile" desktop, as i have read that buying a macbook is essentially a russian roulette with regards to this issue. I love my macbook and was heartbroken that it is at the end of its life (i use it CONSTANTLY.. there are a few reasons it is going to need to be replaced soon), and i would LOVE to stay with mac. I just find this issue unacceptable :( Anyone have any advice/input/support/criticism/suggestions?
  2. Pax macrumors 6502a

    Dec 12, 2003
    have you tried all the steps on here?

    This problem was common with the early Macbooks. I had one from 2006 and had this problem. I can't remember what fixed it, it ended up with a new logic board and a new battery, but it had so many problems I've lost track of what fixed what.

    IIRC the x means "battery not recognised". This implies to me that the Mac can't interrogate the battery logic board (there's a small CPU in the battery to manage charging). The Apple article hints at this as well. If so a new battery MIGHT fix it.

    Have you tried SMC reset? Long shot but it might work.

Share This Page