Macbook Blue Screen Pauses w/Leopard - even after erase and install :(

Discussion in 'MacBook' started by badpup, Nov 9, 2008.

  1. badpup macrumors newbie

    Joined:
    Nov 9, 2008
    #1
    Hello all!

    My sisters rev A macbook (Core Duo 1.83/1gb memory) is suffering with the common Leopard blue screen pause just before logging in. In this case there is however a difference.

    I've not performed an upgrade install, this is a fresh erase and install.. and i have no third party software installed.

    Symptoms are:
    The machine will boot up so far and then sit at a blue screen for several minutes (time varies) before displaying the login list. Sometimes while paused at the blue screen the white screen with apple sign will flash back up momentarily before proceeding.

    Thing is all current solutions seem to point to archive and installing leopard, but I can't see how that would make any difference - seeing as I've performed a fresh install.

    Tech Tool Pro 4 doesn't find any issues with the HDD or memory, and I haven't made any hardware changes. I've reset the PMU/PRAM also, and there are no external devices attached.

    I've installed more than once now with our Leopard retail disc (we got a 5 user for our family) and no change.

    Does anybody have any ideas of what to try next?
     
  2. badpup thread starter macrumors newbie

    Joined:
    Nov 9, 2008
  3. CalMin macrumors 6502a

    CalMin

    Joined:
    Nov 8, 2007
    #3
    Take it to Apple and get a Genius to look over it. Several minutes isn't right.
     
  4. badpup thread starter macrumors newbie

    Joined:
    Nov 9, 2008
    #4
    Thing is her applecare ran out a while back (I think) so I'm not sure the genius will look at it?

    They charge some hideous rate right?
     
  5. LED macrumors member

    Joined:
    Oct 23, 2008
    #5
    I would still suspect the hard drive despite the Tech Tool results. When sectors go bad on hard drives, it can take a long time to read. Since you've done a fresh install, its not the OS. Drives are cheap, so I would suggest picking up a new drive and doing a fresh install on it.

    Also, you might want to run memtest to see if your RAM is stable.
     
  6. badpup thread starter macrumors newbie

    Joined:
    Nov 9, 2008
    #6
    Thanks for the info mate.

    I did suspect the drive.. but the same happens when I run leopard from a USB external drive.

    I've changed the memory out for a 1GB stick from my iMac alu and no change :(

    I'm really stumped.

    I was reading a thread the other day that reports this kinda behavior between certain older PPC machines and early macbooks.. nobody offered a solution though.
     
  7. badpup thread starter macrumors newbie

    Joined:
    Nov 9, 2008
    #7
    Okay I managed to fix this after several evenings of messing about.

    This evening I tried booting into single user mode (apple+s at boot) which sent the machine into a kernel panic displaying endless reams of errors about the firewire port.

    So I took matters into my own hands, by disabling the firewire port.

    I did this by deleting all '.kext' files relating to firewire in /system/library/extensions/ and rebooted.

    Sure enough upon restarting the system it booted up without a hitch and runs really nicely now!

    Sure the machine is without FW (for now).. until I manage to work around this... but its usable again :)
     

Share This Page