Macbook boot issue: Machintosh HD couldn't be verified completly

Discussion in 'MacBook Pro' started by cymrak, Sep 10, 2016.

  1. cymrak macrumors newbie

    Joined:
    Sep 10, 2016
    #1
    Hello. I was watching youtube video when my mackbook pro retina turned off. When i tried to turn on it, i had no success: OS X starts loading and then my mac turns off again.

    1) I tried some options to fix this issue:

    2) I tried Recovery HD - same result. It starts loading and then turns off

    3) I tried to use Disk Utility to check and repair my HD (Command+R during startup -> Disk Utility). So DU doesn't see Machintosh HD volume and i cant check it to repair

    4) I tried to reinstall OS X and during installiation instructions i couldn't proceed because i wasn't able to select any volume to install OS X (there was empty list)

    5) I tried fsck and /sbin/fsck_hfs and i get next errors after "**Checking catalog file" raw:
    a) Failed to issue CON RESET successfully after 3 attempts. Failing...
    b) disk0s2: no such device
    c) The volume Machintosh HD could not be verified completly
    d) disk0s2: no such device
    e) Failed to send exception EXC-CORPSE_NOTIFY. error code: 5 for pid 58
    f) /dev/rdisk0s2(hfs) EXITED WITH SIGNAL 10
    h) After this my mac turns off again

    6) I tried verbose boot option - same result

    7) I tried single-user mode and i got some kind of success: i can navigate through my folders and files and watch content of my files. It seems that my data is OK and hard drive too, isn't is? But when i try to create new file (touch file for example), i get an error, that fs is mounted in read-only and i can't mount it in read write mode. Also i get "I/O errors"

    So can you help me with some advice? I thought that my HD is dead but i can access and read my files in single-user mode, but I can't mount flash drive or copy files. What do you think about this? Is there any way to backup my data on flash device? And should i try something or i should go to Service Center?

    Thx
     
  2. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    I think what I would do first is....

    1. Get an external USB drive and connect it.
    2. Boot into Safe Mode
    3. Download CarbonCopyCloner. CCC is FREE to download, and it's FREE to use for the first 30 days.
    4. Use CCC to create a bootable cloned copy of the internal drive to the external. (assuming you can do this without a forced shutdown).

    Why do this?
    Because if you have to reinitialize the internal flash SSD, you are now BACKED UP with an EXACT COPY of the internal drive.

    You could even try booting from the cloned backup to see what happens.
    Do you get "a good boot" that way?
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Sounds like you have a failed drive or a failed drive cable. I would replace both then once you get the OS installed on the new drive, try putting the old drive in an external USB enclosure and see what data you can recover.

    Do not try Disk Utility or reinstalling anything on the old drive. All that does is reduce your chances of being able to recover data from the drive.
     
  4. cymrak thread starter macrumors newbie

    Joined:
    Sep 10, 2016
    #4
    Hi, Thx for you answer. But i can't get "a goot boot" in safe or verbose mode. I get same error like in fsck command case. Only one way when i get "a partial good boot" is using single-user mode. I can view my files and read its data using "vim" editor for example. But can't modify anything and mount any device
     
  5. tubeexperience macrumors 68030

    Joined:
    Feb 17, 2016
    #5
    Maybe you need to get a new SSD. You can buy one from Transcend or OWC.
     

Share This Page