Macbook can connect to internet, but webpages won't load.

Discussion in 'MacBook' started by cripplerking, Jun 1, 2010.

  1. cripplerking macrumors member

    cripplerking

    Joined:
    Oct 18, 2008
    #1
    So having recently relocated myself and my Macbook to the summer camp where I work, I was annoyed to discover that it is having internet problems. It can see the camp wireless network, and gets a least two bars, but whenever I try to load a page in a browser, it usually waits a good long while then gives me a server problem error. I've tried using Chrome, Safari, and Firefox, and they've all had the same result.

    Interestingly enough however, when I boot into the Windows XP partition of my hard drive, it detects internet fine, and works perfectly. So I know this isn't a hardware problem.

    Since this problem began, I've tried several fixes, including messing with my firewall, resetting the Internet (although my Macbook may have been off at the time), and examining my Network preferences. Nothing has helped, and I was really hoping someone here could lend a hand.

    For reference, my Macbook is a 2008 Unibody Aluminium model, running Snow Leopard. I'm pretty sure it's never had this problem before.
     
  2. sbbrown333 macrumors member

    Joined:
    Sep 6, 2009
    Location:
    Upstate SC
    #2
    MacBook Internet connects but webpages won't load

    Did you ever find a fix to this problem? I'm having the same issue
     
  3. millerj123 macrumors 6502a

    Joined:
    Mar 6, 2008
    #3

Share This Page