Macbook can't connect to internet

Discussion in 'MacBook Pro' started by camobag, Dec 27, 2007.

  1. camobag macrumors regular


    Nov 4, 2003
    I have a blackbook (intel core 2 duo) and I can connect to my landlord's wireless network (they have a netgear wgt624) but I can't actually use the web (Safari or Firefox will just "think"). I've tested the diagnostics and it confirms that my mac can connect to the network, but it cannot connect to the internet. The network uses WPA personal and it has a 19-aphanumeric passphrase. Can ANYONE help me??

    It may be the firmware...

    *Also - would it be possible for me to extend the wireless range (and make it possible to browse the web) if I used my own 2wire wireless modem to connect to the netgear wgt624?
  2. kajitox macrumors 6502a


    May 2, 2007
    Is this wireless network working for other people? If the router is plugged in, you can connect to it, but it doesn't necessarily mean that any modem is connected to it, etc.
  3. ftaok macrumors 603


    Jan 23, 2002
    East Coast
    Do you have the passphrase?
  4. camobag thread starter macrumors regular


    Nov 4, 2003
    The wireless network is working for everyone else but wife has a g4 iBook that seems to be surfing the web fine as well as my landlords' pcs.

    To answer the other question, yes, I do have the passphrase and I can connect to the network. The problem is is that I can't actually get online.

    *Also, my Tivo doesn't seem to be working on the network either...even though I have the wireless adaptor which is supposed to work with WPA encryption.
  5. MacinBako macrumors newbie

    Feb 14, 2008
    I can't connect either

    I have a similar problem. I'm using a MacBook running OSX.5. I can connect to my WGR614 router to print/file share. No Internet, though.

    The other computers on the network (ethernet and wireless) connect, no problem.

    I turned off all security features on the network to see if that was the problem - no luck.
  6. Rich26ca macrumors newbie

    Mar 21, 2009
    As am i not sure whats happening really... I have macbook core duo 2.4 2gb @ 1067mhz

    my internet was working before but not anymore.

    have a D-link 615 router and a windows based PC (MSXP) that is wired to the router and is running fine. hense me writting, lol...

    My Mac however is not able to surf.

    it can see the router but can't connect to it. can't use to access the router either wired or wireless.
  7. ViciousShadow21 macrumors 68020


    Mar 11, 2009
    To your left or right
    a friend of mine with a D-Link router had this problem over a couple days ago and the only way i found to fix it was to reset the router back to factory settings. there is a paper clip hole on the back of the router that you push down for 10 seconds.
  8. relyuc macrumors newbie

    Feb 23, 2010
    Beijing, China
    Is anyone still following this topic and able to help?

    I'm using a white Macbook (Intel Core Duo) with OS X.6. Recently my mac stopped finding the Internet despite being connected to wireless networks. I can connect just fine to the networks, but no websurfing.

    I thought it was the coffee shops that I was at, but Monday set up my home network running a PPOE through my Airport Express Base Station. I set up the network on this computer, but can't get on the internet. My iPhone, flatmate's computer and my girlfriend's computer (both running Windows) have no problem accessing the internet through said wireless network.

    As I said, the problem started prior to setting up this home network... I cannot access the Internet through all other wireless networks I've tried, that is public ones at coffee shops. Thus I'm basically one hundred percent sure the problem is with this computer. Do I have to change something in my mac's network settings for the airport?

    Any thoughts? Thanks!
  9. NoAxAxon macrumors newbie

    Jun 12, 2010
    Something simple worked

    I've been helping a relative with this and have been following this thread for a long time, until I just hit upon the solution.

    In our case, at least, at least, the WEP password could look like a HEX number, a decimal number or an alpha password.

    We are using a D-Link wireless router and a WEP HEX password. All we had to do is put the $ (dollar sign character) in front of the WEP password when entering it on the MAC.
  10. bigjobby macrumors 65816

    Apr 7, 2010
    London, UK
    This is what I did and it worked for me. During my investigations before the reset, I found my MBP's DHCP issued IP address was conflicting with another wireless device with a DHCP IP which was kinda weird. There was no warning messages either which was a pain. Did the reset, reconfigured the switch/router and gave the MBP a reserved IP and all's been well since.
  11. afrank11 macrumors newbie

    Jun 25, 2010
    Problem is same for me with WPA Personal

    I have been looking all over for a solution. At home my Mac drops connections frequently and then switches to other available networks automatically. Today, i am visiting for a week and there is no ability to reset someone elses router. It seems pretty weird that every windows machine can work and only the Mac is having trouble. They are using DSL with at Linksys WRT110 router. I have searched the internet high and low. The $ solution does not work with WPA because it is not a hex password. Anyone find another solution that actually fixes the problem? Thanks. I repost if I find one. My problem is I can get access to the router fine. Just no connection to the internet.
  12. NZMacBoy macrumors newbie

    Feb 19, 2011
    Please help me

    Hi there, I have the exact same problem as described above. Anyone knows the solution to this? My Macbook Pro was connecting to the wireless network fine without issues. I had a bulging battery issue so took it to the Mac retailer and they said it needs a new battery. I bought the new battery and switched on. Since then my MBP can connect to the network all right wirelessly but just can't access the internet. Funny thing is that I even tried the hard wired lan connection and the status said connected, but when I goto browse - I can't access the web. I used the same lan connection on my windows laptop and without changing any settings, it worked straight away. I just can't understand what the issue is with this MBP. It has developed this suddenly and I hope it is just some weird setting, and nothing actually physically wrong.

    Can anyone help me please? Can't believe Mac's are so complicated when an issue arises.

  13. pommehomme macrumors newbie

    Dec 3, 2010
    iMac FP sees LAN, is supposedly connected but cannot connect to Internet

    I am usually pretty good but this one has stumped me. All of a sudden one of my iMac FP with OX 10.4.11 will not connect to the internet. It is connected via built in Ethernet to a powered hub which is then connected to my LAN via Linksys router then Comcast cable modem to internet. All other computers on the network (including those connected to the same powered hub) can connect normally.

    Network preferences: "Built-in Ethernet is currently active and has the IP address You are connected to the Internet via Built-in Ethernet."

    But I can't connect. Changed the cable from the iMac to the hub: no difference. Both Firefox and Safari say I am not connected.

    Suggestions appreciated for further troubleshooting or treatment. Is my iMac dying?


Share This Page