Macbook can't find my internal HD?

Discussion in 'Mac OS X Lion (10.7)' started by Rock69, Feb 12, 2013.

  1. Rock69 macrumors newbie

    Joined:
    Feb 12, 2013
    #1
    My Macbook Pro 13' with Lion 10.7 was behaving weirdly for the first time since I bought it in 2011 so I forced restart, as it wasn't restarting through the system.

    When it booted, it went straight to the Mac OS Utilities. I tried the Disc Utility but it found no errors. I tried reinstalling Lion but it says Disc Locked. I tried the NVRAM thing but nothing changed. I tried Time Machine but it keeps trying to find one backup and nothing happens, it just keeps searching endlessly.

    So when I tried booting up pressing Option, the only available HD is the Recovery HD. Does that mean that the system somehow "lost" my HD? :confused: What are the next steps? I already booked an appointment at the Genius Bar but it's only on Sunday and I have urgency on fixing this, if it is possible in any way.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try holding command-r when you boot to get to the Recovery partition. Once there start Disk Utility and run a repair disk on the main drive and see what that says.
     
  3. Rock69 thread starter macrumors newbie

    Joined:
    Feb 12, 2013
    #3
    Nothing happens when I hold command-r, it still prompts to the OS Utility.
     

Share This Page