Macbook Can't read USB devices

Discussion in 'MacBook' started by mmellado, Mar 30, 2009.

  1. mmellado macrumors newbie

    Joined:
    Feb 12, 2009
    #1
    I tought that the problem was with my specific usb device, but i'v already tried with the 2 USB ports and with several usb devices. Everytime I insert a USB device into my computer, a screen appears saying that i need to turn off my computer and that i need to click on the power button for several seconds to do so. This has become pretty annoying since i can not transfer files nor make any backup on my computer because everytime i insert a usb (external hard drive or simple usb device) the screen appears and i don't know what to do. Does anybody know the reason why this is happening or a solution for this problem?

    Correction: It only happens with storage devices, whenever i connect my iphone 3g, it works normally
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
  3. mmellado thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    #3
    Sigh i reformatted about a month ago haha i hope the SMU Reset fixes it because if not i will be REALLY pissed by having to reinstall Tomcat and some other stuff that took me ages to install hahaha. Ill try SMU Reset and give my feedback after it.
     
  4. mmellado thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    #4
    HAHA i need ot read better, SMU is for Power Mac... so SMC reset would be the equivalent for a macbook?
     
  5. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #5
    yes. the thread also suggests going to 10.5.6.
     
  6. mmellado thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    #6
    i havnt got the time to reset smc, but i am already on 10.5.6, i think i will try to do it this weekend since im extremley busy with my exams and stuff
     
  7. mmellado thread starter macrumors newbie

    Joined:
    Feb 12, 2009
    #7
    Problem Fixed

    just giving a feedback on how i solved my problem... i tried a lot of things.. the SMC reset didn't work at all, so i reinstalled the OS. Ididnt format my computer tough, i just reinstalled saving my data (its the second option given by the installation cd) When i finished reinstalling i still had all my files, and my programs, only thing i needed to do was reupdate evrything (itunes, quicktime etc...) Hope this can help somebody in the future...
     

Share This Page