MacBook can't recognize Iomega Network Attached Storage Ethernet External HD??

Discussion in 'Mac Accessories' started by dominordelingua, Oct 4, 2009.

  1. dominordelingua macrumors member

    Joined:
    Jun 26, 2008
    #1
    I'm not really sure why this is happening. I bought the Iomega Home Media Network Hard Drive 1TB the other day since it claims to be Mac compatible. I set it up correctly, attaching power cord and ethernet cable to router. Afterward my Windows PC had no problem recognizing the drive and mounting, but my MB couldn't see it at all, so I couldn't even format it to FAT32 if I wanted to. I already tried connecting by IP address, which worked once, but never again. I also tried connecting directly by ethernet, but no result. Has anyone had any similar experience? and did you find a way that worked? am I missing anything?

    Also, I'm thinking of returning the HD and getting something else. Does anyone have any recommendations for a long lasting External HD that is preferably NAS, though its not required.

    Thanks all
     
  2. gabor macrumors newbie

    Joined:
    Oct 4, 2009
    #2
    The Iomega Home Media Network Hard Drive is not compatible with Snow Leopard, only older versions of Mac OS.
     
  3. dominordelingua thread starter macrumors member

    Joined:
    Jun 26, 2008
    #3
    I'm still running 10.5, so supposedly there shouldn't be a problem. Ironically I purchased Snow Leopard the same day. I haven't installed it yet because I was planning on backing up my system before doing a clean install of SL.:rolleyes:

    Oh well, I'm planning on returning the HD soon, so any suggestions or tips on what to look for in a Snow Leopard compatible external HD would appreciated.

    Thanks
     
  4. skarocks47 macrumors member

    Joined:
    Sep 26, 2008
    #4
    Not True

    This is not true. I am running SL and i set mine up the other week. I plugged in the drive and put in the Iomega CD in and installed the manager (Btw i hate the software, so i unistalled it later). It found my hard drive and mounted it for me. But later on the drive disconnected like yours did but i could still acess it from web interface and set up a user account on all of the files and then mounted the drive manually through "go" And "connect to server".

    It has worked ever since. If your looking to do time machine backups to it. Then thats another story since SL broke backups to NAS other than Mac approved drives. There are work arounds though.
     
  5. quantum003 macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #5
    Why not return the dippy Iomega thing and buy an Airport Extreme Base Station with the money instead? Then you could connect any old external hard drive you have to it via USB and the drive becomes accessible through the wireless network to any other computer in the house.
     

Share This Page