Macbook connected to internet, but can't load webpages.

Discussion in 'Mac Basics and Help' started by cripplerking, Jun 4, 2010.

  1. cripplerking macrumors member

    cripplerking

    Joined:
    Oct 18, 2008
    #1
    My basic problem is this: my Macbook (2008, Unibody, running Snow Leopard) can connect to the wireless network at the camp where I work, getting two bars, but cannot load webpages. Instead, it takes a while, then tells me the connection is timed out or the server isn't responding.

    This issue is frustrating because I CAN connect to the wireless network when I boot my Macbook into its Windows XP partition. This makes me think it isn't a hardware problem, but probably software.

    Thus far I've tried resetting the network and fiddling with the Network Preferences, but nothing's worked. Can anybody here help me?
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Try placing the network at the top of the list of preferred networks.
     
  3. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #3
    Being connected to a wireless network does not necessarily mean you get internet access.

    Check your Network Preferences to be sure you're getting a proper IP address, DNS, etc.
     
  4. bbazzahh macrumors newbie

    Joined:
    Jun 3, 2010
    #4
    Network Utility > Ping www.google.com then the IP address of google. Post the results

    Differently try inputting your ISP DNS addresses manually.

    Its not a hardware issue
     
  5. cripplerking thread starter macrumors member

    cripplerking

    Joined:
    Oct 18, 2008
    #5
    Unfortunately, I have no experience with handling network stuff. Could someone explain more in detail how to input my ISP DNS addresses manually? How can I tell if I"m getting a proper IP address, DNS and such?
     
  6. spinne1 macrumors 6502a

    spinne1

    Joined:
    Mar 12, 2005
    Location:
    Hermitage, TN USA (near Nashville)
    #6
    Maybe a quick fix:

    Open System Preferences, then Network. Look to the right of the main window. Configure should say "Using DHCP." DNS Server might have some numbers in it. If so, write down those numbers and put them in your wallet. Now erase the numbers. Now, hit the "advanced" button and make sure the TCP/IP tab is selected. Hit the "Renew DHCP Lease" button. Hit "OK." Hit "apply" once back to the main window. Now try to get on the internet. Does it work? If it does it could be that your DNS Server numbers were trying to look up a server that you are not connected to, or in other words they may be set to your home ISP DNS server numbers. If it does work, just put the correct numbers back (four numbers separated by a period, with a comma and a space in between groups of numbers) when you get home.
     
  7. cripplerking thread starter macrumors member

    cripplerking

    Joined:
    Oct 18, 2008
    #7
    I figured it out. It was something to do with the IP address I think; I entered in manually and now I'm getting internet. Thanks for all the help and suggestions though guys!
     

Share This Page