Macbook connecting to wrong internet

Discussion in 'Mac Basics and Help' started by Big Stevie, Jul 14, 2015.

  1. Big Stevie macrumors 6502a

    Big Stevie

    Joined:
    Jun 20, 2012
    Location:
    UK
    #1
    We have 2 x BT Infinity broadband supplies to our house, one downstairs for the family and one upstairs in my wifes office (Belkin router).

    My 2012 macbook pro always connects to the upstairs Belkin router, despite the fact that Im sitting with my macbook only 5 ft away from the downstairs Infinity router. It takes a couple of minutes before my macbook recognises the downstairs connection, and then I have to change to it manually. This is despite having set the downstairs connection to the top of the list in Wireless Network Preferences.

    I could delete the Belkin router from Network Preferences but its connected to a printer in my wifes upstairs office, which I occasionally need to use.

    Any suggestions on how to always connect to the downstairs router by default please?
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Try changing the Infinity wireless security to WPA2-PSK. Also ensure that OS X is fully up-to-date.

    Failing that, try SMC/PRAM reset.
     
  3. Big Stevie thread starter macrumors 6502a

    Big Stevie

    Joined:
    Jun 20, 2012
    Location:
    UK
    #3
    Its currently WPA/WPA2 Personal. The upstairs Belkin is WEP. Would that affect things?
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Possibly. Would you be able to change it to WPA2-PSK only and see if that makes a positive difference? Also is the channel static or auto assigned?
     
  5. Big Stevie thread starter macrumors 6502a

    Big Stevie

    Joined:
    Jun 20, 2012
    Location:
    UK
    #5
    Just done the PRAM reset, but still no joy.

    Not sure how to change to WPA2-PSK, or how to see if its static/auto assigned. Would you kindly elaborate please?

    Thanks
     
  6. flat five macrumors 601

    flat five

    Joined:
    Feb 6, 2007
    Location:
    newyorkcity
    #6
    rearrange the order of preferred networks?

    System Preferences -> Network -> Wi-Fi -> Advanced

    drag the one you want to try connecting to first to a higher position in the list than the other..
     
  7. Big Stevie thread starter macrumors 6502a

    Big Stevie

    Joined:
    Jun 20, 2012
    Location:
    UK
    #7
    Thanks but its already at the top of the list, and the Belkin is at the bottom.

    My iPhone and iPad connect to the downstairs internet straight away, its just my macbook that insists on connecting to the upstairs internet.
     
  8. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #8
    Is there a reason you want two separate networks? I would personally use identical settings on both the Belkin and the other router that way the clients can freely roam between APs. Furthermore, WEP is horribly insecure and should not be used in any modern networking environment.
     
  9. hiddenmarkov, Jul 14, 2015
    Last edited: Jul 14, 2015

    hiddenmarkov macrumors 6502a

    Joined:
    Mar 12, 2014
    Location:
    Japan
    #9
    off
    To kind fix this they could go into the settings and...

    limit DHCP to max number of clients
    restriction based off mac address

    This would also solve their hitting the network, it will both be filled and denied via mac restrictions.

    Still can be eavesdropped technically but wandering into the network not possible (barring someone knowing a mac address in the list to spoof it anyway)

    Another option is for the work AP to turn off SSID broadcasting. it will still be broadcasting a wireless network but not advertise it. If not advertised you have to actually look for it and manual put information to reach it.


    Turn off SSID broadcast
    config office resources to see it typing in its info and credentials to access it
    wipe connection off non work mac
    non work mac will never see this WAP again to just hop on it automatically. It has to be programmed in.


    Mention of needing the printer sometimes so just join as needed, delete network connection when done.
     
  10. Big Stevie thread starter macrumors 6502a

    Big Stevie

    Joined:
    Jun 20, 2012
    Location:
    UK
    #10
    My wifes employer installed a broadband connection for her to work from home, she has to use this dedicated broadband supply isn't allowed to use the home broadband.

    I've now deleted this broadband from my macbook, and will as hiddenmarkov suggests simply connect back into it when I need to print.

    But I'm baffled as to why this happened. Im assuming that the upstairs Belkin broadband must be a stronger signal than the home broadband located just 5 ft away from me? Even though id moved the home broadband to the top of the MacBooks connection list, it still always connected to the Belkin Strange!!
     
  11. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #11
    If it's anything like my virgin router was, all my hardware saw the 2.4ghz network quicker than the 5ghz network so hopped straight onto that.

    So my thinking is the belkin is running 2.4ghz and your infinity is running a 5ghz band.
     
  12. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #12
    DHCP Limits do not apply to static configurations generally. Say I saw your network and knew it used the 192.168.1.x range. You setup a DHCP limit so it only goes to 192.168.1.20 for instance. All I have to do is setup a static configuration of 192.168.1.21 and I am in. That offers no security whatsoever.

    MAC Address filters are also horribly insecure. It does not take much for someone to simply spoof a MAC address and thereby your filter becomes useless. To the router, it appears as if you are a trusted client on the access control list when it could be a total dirtbag sitting outside in a vehicle stealing network data.

    Finally, disabling AP broadcast brings its own vulnerabilities. While the network would disappear from view, clients have to call out this information in a search for it. That is like me living at my address, then going to the local mall and screaming out my address. No one knows where I actually live but they know what to look for.

    The methods you describe pale greatly in terms of security to using an up to date encryption method (WPA 2 PSK). Remember that while nothing is impregnable, the best one can do is keep a good stand on security.
     

Share This Page