Macbook constantly restarts & won't boot from CD Drive

Discussion in 'MacBook' started by daenterpri, Mar 26, 2010.

  1. daenterpri macrumors newbie

    Joined:
    Mar 26, 2010
    #1
    Hello!

    I have a previous generation 13" macbook with the aluminum case but no graphics card.

    Anyways, it recently started not going past the grey screen and it wont stop thinking. I tried booting from the CD drive, and once selected, it just restarts rather than booting into the CD drive.

    I did all of the resetting of the Pram, holding down the power button for 10 seconds, etc...

    So, I tried removing the hard drive and putting it into an external enclosure, then with my Macbook Pro, loaded Leopard OSX onto it after erasing the drive.

    The method I used for loading the OS was simply putting the Leopard CD into my MBP drive, and then going through the normal install process after restarting but selecting the external drive rather than my MBP to install it on. It appeared that it went well, and even restarted, booting into the external drive. It wanted me to go through the setup process.

    However, when I put it back in the Macbook, it now just constantly restarts before you see the apple logo, and refuses to even give me the option of booting from CD.

    What do you guys think? Logic board? Motherboard? Or should I try something else?

    Thanks,

    Andy
     
  2. daenterpri thread starter macrumors newbie

    Joined:
    Mar 26, 2010
    #2
    Any takers? I tried removing one stick of ram at a time this evening to see if that would do anything. It didn't.
     
  3. benfeingold macrumors newbie

    Joined:
    Apr 1, 2010
    #3
    Exact same problem: Booting over and over...

    I had a user complaining that her MacBook (early 2009) wasn't allowing her to save to network drives so I backed up her data, wiped the drive, started it in Target Mode and the reinstalled the system from a disk image. I do this several times a month with the same image.

    When I attempted to boot up with the fresh install, the MacBook would chime, go to the grey screen, pause, go black and then repeat - over and over.

    I figured there must be something wrong with my Disk Image so I popped in my 10.5 DVD, held down OPTION and when prompted, selected the install DVD. Same thing happened. I've since retried the Disk Image, zapped the PRAM, switched the memory and still nothing.

    Currently I'm attempting to install 10.5 to the problematic MacBook (which is in Target Mode) from my personal MacBook. It appears to be loading fine. We'll see what happens when it finishes and I restart.

    Is there a way to reinstall the Firmware that deals with startup? Anyone else having this problem? Anyone have a solution.
     

Share This Page