MacBook declaring connected Epsom Printer "Offline"

Discussion in 'Mac Basics and Help' started by milamilano, Jan 28, 2013.

  1. milamilano macrumors newbie

    Jan 28, 2013
    I connected a new Epsom printer to my Macbook Pro a month ago. It worked perfectly, both wirelessly and with a cable. I turned on the printer for the first time in a month and though it has a green light for Wifi (meaning functioning) and it does a test print fine, it will not connect to my Macbook which although is able to find the printer, it declares it "Offline". I have tried both wirelessly and cable to no joy. I have tried reinstalling the Epsom driver, I am at a loss for what to do next. Could anyone help? Grazie!
  2. Shrink macrumors G3


    Feb 26, 2011
    New England, USA
    While I can't give you a solution (when I have problems, I call Epson Tech Support), I would suggest that there is no real reason to ever turn the printer off. With mine (Epson Stylus NX 530) a few minutes after use, it sleeps, and draws no juice, for all practical purposes. After you get back online, I suggest you just leave it on.

    Sorry I can't help with getting it back online...:eek:

Share This Page