MacBook does not recognize USB headset mic unless plugged into hub

Discussion in 'Mac Basics and Help' started by Succendo, Feb 25, 2010.

  1. Succendo macrumors newbie

    Joined:
    Feb 25, 2010
    #1
    Here's my puzzler of the moment: I have a Creative USB headset (the Fatal1ty gaming headset for Mac, which I bought at an Apple store). It's been working fine via USB (with the notable exception that it stops working easily if even slightly jostled).

    In the last few days, however, it stopped working when plugged directly into the Mac. The audio out still works, and it shows up as an audio input device, but when selected it does not detect any incoming audio.

    I assumed it was a headset problem until I tested it plugged into a USB hub - plugged into the hub, it works fine.

    I'm not sure where to go from here - I tried resetting the PMU, which is the nearest I can find to releasing USB memory, as well as leaving the machine powered down with all devices unplugged for several minutes - no joy.

    Any ideas?
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    This is just a guess, but the fact that it was touchy to physical movement from the beginning might be related. If there were some small short or other physical problem that recently got worse, it's possible that the Mac is glitching out on it while the hub either supplies enough power that it doesn't matter (they're usually much less strict about how much current they'll supply) or is just more tolerant of whatever is wrong.

    I'd rather expect it to not work at all when plugged into the Mac in this situation, but it's possible. Have you tried wiggling the cord around to see if it kicks back in, which would point you to a hardware problem?

    Just to give a comparison, USB devices are only supposed to draw 0.5A at max, but some things (particularly bus-powered optical drives) can attempt to draw 1A or more. I had an optionally bus-powered slimline optical drive that, when plugged into a Mini directly would shut it down completely. Plug it into a powered hub, though, and it worked fine, since the hub was willing to supply way more current than the spec allows. Similar thing happened when I tried another drive on my own, newer-model mini; with only bus power, it behaved erratically and would drop out when it tried to spin a disc up. Give it external power, though, and it worked perfectly.
     
  3. Succendo thread starter macrumors newbie

    Joined:
    Feb 25, 2010
    #3
    A couple more key facts you made me think of -

    Wiggling does not change anything when plugged into the MacBook. Additionally, the symptoms are the same in both USB ports, although they both used to work and failed separately (I.E. for a while the headset was fine in only one port, then didn't work in either).

    Additionally, the USB hub is not powered - it's just straight from the MacBook.

    My suspicion has been some kind of corrupted driver or USB settings issue - in Windows I would delete the entries in the Device Manager, but I don't know a comparable step on the Mac.
     

Share This Page