MacBook does not run on AC power alone

Discussion in 'MacBook' started by MacRuud, Apr 13, 2010.

  1. MacRuud macrumors newbie

    Joined:
    Sep 4, 2006
    #1
    MacBook stopped charging the battery and will not work with AC power adapter only. MacBook notices the power adapter is connected, but reports battery not charging. Adapter light stays green even when battery needs recharging. MacBook runs fine on battery power.

    Installed battery update 1.4. No change, switched back to 1.2.
    Checked the battery (Cycles 66, Condition: good; does charge on onther MacBook).
    Checked the AC adapter (works fine on other MacBook).

    Logic board failure?
    Could it be a problem in the DC-in board (I think this is only a connector)?
    Would resetting the PMU be usefull?

    MacBook Core 2 Duo 2.16 Ghz (A1181)
     
  2. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #2
    Does your Macbook charge using a different Magsafe? Might be worth a final check like that. It could be something as simple as gunk in your Mac's Magsafe port. Trying another Magsafe would eliminate that possibility.

    Possibly a DC in board. We've had a couple of people on here report failures. As you say I think it's just a connector.

    SMC reset is always worth a try. I think 99% of the time it has no effect, but it never makes things worse.

    It could be the logic board, seems unlikely. There was a spate of Macbooks which failed to recognise the battery (x in the menu bar battery icon). The fix was a new logic board. But I believe this was down to some handshaking problems between the battery CPU and the Mac CPU. If your Mac recognises your battery I hope you are OK with respect to that.

    What does the Mac report for battery voltage? It won't charge it until the voltage drops below something like 12.55 V (IIRC). If the internal voltmeter is fried that could be the problem. If you like you could post all the power info from System Profiler on this thread.....
     
  3. eman macrumors 6502a

    Joined:
    Nov 5, 2007
    Location:
    In the great white north
    #3
    Has this macbook had a liquid spill? Things to try:
    1. Try a different battery or try your battery in different macbook.
    2. Could be faulty battery connector.

    Also, the charging circuit could be out on the logic board.
     
  4. MacRuud thread starter macrumors newbie

    Joined:
    Sep 4, 2006
    #4
    Follow up

    re Pax:
    - tried charging with other Magsafe: didn't work.
    - wil try a SMC reset (is this same as PMU?)
    - battery is recognised, MacBook works fine when battery is charged on other MacBook
    - Ia pdf of the power info window is enclosed as an attachment to this reply.

    re eman:
    - no liquid spill
    - tried charging other (new) battery: didn't work
    - did a visual check of the internal battery connector: seems okay to me
    - is there a way to specifically test the function of the charging circuit on the logic board ?
    - guess the charging circuit is an integral part of the logic board?
     

    Attached Files:

  5. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #5
    Yes, SMC reset is the new name for PMU. For a non-unibody it's take the battery out and hold the power key for something seconds. For a unibody it's a 4-finger salute on the keyboard. Apple.com will tell you exactly how.

    Thanks for the PDF. Everything looks normal. Battery voltage, discharge current, Mac recognises charger etc.

    So it just won't charge. I can't think what other diagnostics you can do. Maybe eman can think of some.

    I am starting to think this is an SMC firmware problem not hardware. I guess the SMC uses a number of tests to determine whether to charge the battery or not. For your Mac.....
    1 - the SMC knows a valid battery is installed, so charging is a valid option
    2 - the SMC knows its voltage is <<12600 mV so it needs charging
    3 - the SMC knows a valid Magsafe is connected, so it could charge if it wanted to

    But the fact that the Magsafe always shows a green light seems to hint that the SMC doesn't want to charge the battery even though its charging criteria are fulfilled (I think the SMC tells the Magsafe what color light to show). Could this hint at a firmware problem not a hardware???????

    I could imagine a hardware problem causing either...
    - one of the 3 tests for charging to fail, causing the SMC to not want to charge, or
    - current to fail to reach the battery. But in that case I would expect the Magsafe light to go red, and the System Profiler to say "Charging: Yes" but for current not to reach the battery

    Maybe there are more tests the SMC applies before it charges. Maybe those tests aren't exposed to the user in System Profiler.
     
  6. student_trap macrumors 68000

    student_trap

    Joined:
    Mar 14, 2005
    Location:
    'Ol Smokey, UK
    #6
    I have seen this on a few laptops now, including my own, although it does start charging again after a reboot.

    A friend with it contacted apple though and they say that it is normal
     
  7. esadb macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #7
    Sorry to bring this old thread back to life. But any solution to this? I have those exact same problems with the a current C2D.. tried replacing DC in board and battery connector without much luck..

    Anyone know anything??
     
  8. maddmac, Jan 9, 2011
    Last edited: Jan 9, 2011

    maddmac macrumors newbie

    Joined:
    Jan 9, 2011
    #8
    Macbook 13 won't charge battery

    Hi All, I am having the exact same problem with mine. I have the schematics for my Macbook 5.2 13.3" and it shows the PBUS Supply/Battery Charger as the 1st chip ISL6255 to get power it's labeled U8300 on the schematic and I found that # near the pram batt underneth. That is the battery charger chip on my 820-1889-A Logic Board it's about 1/4" square with 7 connecting wires or pins on each side. I plan to trace all circuits till I find the bad one. My macbook works great but only off battery power and that won't charge. Also the sleep LED wont work at all and I know the LED is fine. Thanks for any advice.
     
  9. hfriesen macrumors newbie

    Joined:
    Nov 2, 2009
    #9
    Pictures of charger chip on logic board

    @ maddmac. I have the same machine and same problem. Would you be able to send me or post some pics of this chip or your solutions? email fatphegesfudge@shaw.ca
     
  10. Benqvist macrumors newbie

    Joined:
    May 12, 2011
    #10
    @maddmac

    I'm having the same trouble with my a1229 MBP 17". The cause: The MBP was, when running on battery power, accidentally left to run out of power (to forced shutdown, not to sleep mode) with two external pocket drives connected and running. I suspect that the heavy load situation created a voltage spike that somehow killed the charging controlling chip or a related component.

    Computer does not power on with AC power. The battery won't charge, even though the MagSafe connector gives a red light when connected. Somehow, the computer manages to recognize that the battery needs charge, and gives the "charging" status. But there is no actual charging taking place.

    The battery charging chip sits on the logic board (I think...) and it is called ISL6257HRZ. It is getting 16.94V on the DCIN pin from the AC adaptor (which is confirmed functional).

    Should I attempt to replace this chip? They are very easy to find on eBay, and it has to be a reason for that, I thought... Do you have some other troubleshooting tips from this point? Or any kind of schematic that could be useful in my case?

    Cheers
     
  11. Benqvist macrumors newbie

    Joined:
    May 12, 2011
    #11
    Hope I'm not boring you to death, but I wish to share all my info on this delicate subject.

    Update:
    Managed to fully charge the battery externally with another computer, measured it to about 12.5V with multimeter, all green battery LEDs lighting up.

    Then I put the battery back into my Macbook Pro, and it (drumroll...) refused to start.

    With battery installed, I measured only 0.01 V (!) on the battery terminals, compared to 12.5 V with the battery out of the machine. I verified that the battery <> logic board connection was OK; I measured 12.5 V on the small battery connector cable when it was off the logic board and just paired with the battery.

    Short circuit? Maybe, but there were no sparks or heat when connecting battery. Maybe there is a short circuit protection (inside the battery) that cuts in.

    Moreover, now there is absolutely no visible LED on the Magsafe connector. Thought I fried the AC adaptor as well, but luckily it worked well and behaved normally when connected to another Macbook.

    Battery charging chip totally fried?

    Anyway, most forum threads out there end with solutions like "nothing to do but replacing the logic board"... Would be amazing to actually identify and replace the faulty component on our "vintage" and out-of-warranty Macbooks.

    Cheers!
     
  12. cmdrdata macrumors 6502

    Joined:
    Jun 10, 2011
    Location:
    Dallas, Texas, USA
    #12
    @Benqvist: Try charging that battery with other computer again and see if it goes back up to 12.5v. My guess is it would not. I suspect that your battery just died. The no start is because neither the adapter nor the battery is providing power to the system, including the SMC (in the logic board), thus the SMC cannot communicate with the adapter to set the status LED on the magsafe plug. On the AC issue, on the logic board (the inside side of the LB, there is a DCIN fuse that perhaps could have blown, and thus not allowing charge current to enter. In the logic board, the adapter power and battery power are "OR'ed, so either can provide power to the system power bus, called PPBUS_G3H (and baterry carging comes from this bus). Thus no DCIN means no charging. But if the battery is above nominal value, the SMC will still function and can send signal to the magsafe adapter.
     
  13. Benqvist macrumors newbie

    Joined:
    May 12, 2011
    #13
    @cmdrdata: I think I wasn't really clear before, sorry. The battery gives me 12.5V when out of the computer, but 0.01V when in the computer. When removed from the computer it is immediately back to 12.5V. I get the same results today, 2 days later, without charging. All 5 green battery LEDs light up, regardless if the battery is in the computer or not. I should mention that the battery is quite new (about 8 months of normal use).

    Thanks for the walkthrough!!! I'll try and check the DCIN fuse if I manage to find it.
     
  14. hoylen macrumors newbie

    Joined:
    Dec 3, 2009
    #14
    Fault possibly lies in the logic board

    I have the same symptoms with my early-2008 MB404LL/A model 2.4GHz MacBook. Here's my experience.

    The problem with mine seems to be on the main logic board.

    I took it into Apple and they replaced the DC-in MagSafe board, but that didn't fix the problem. They then offered to replace the logic board, but I didn't think it was worth the expense (since it was water damaged and given the age of the machine). If it was something as simple as a fuse, I assume they would have tried that first before offering to replace the entire logic board. The battery works fine on my other MacBook.

    If you have this problem, based on my experience, don't get your hopes up. It is unlikely to be inexpensively fixed -- unless you have extended AppleCare warranty (and it wasn't water damaged) or want to pursue component level repair of the logic board. I'm not claiming that your problem is exactly the same as mine, but I hope my situation helps you decide what to do next.
     
  15. DanMacApple macrumors 6502

    Joined:
    Jul 1, 2010
    #15
    It does sound like it could be a logic board problem.
     
  16. cmdrdata macrumors 6502

    Joined:
    Jun 10, 2011
    Location:
    Dallas, Texas, USA
    #16
    I haven't this forum topic for a while, but here's some additional info: in my MBP unibody with internal battery, the connector is a 9-pin type, 3 for ground, 3 for V+, SMC+ and SMC-, and one for system sense (center pin). Measuring the V+ to GND with the connector disconnected from the system I get 0 volt. If the sense pin is connected to GND with a 10 kOhm resistor, the V+ to GND shows 12.5 volts. Since your connector is 7-pin type, it may not have the same pin out as mine. YMMV.
     

Share This Page