Macbook Doesn't boot at all!!!

Discussion in 'MacBook Pro' started by marconairam, Jan 26, 2008.

  1. marconairam macrumors newbie

    marconairam

    Joined:
    Jan 26, 2008
    Location:
    Maexio City
    #1
    I have a first gen macbook and was trying to upgrade it to leopard. When it had already installed about 10% i got a kernel Panic error and got a message that asked me to shut down the computer.

    The problem is that now its not booting into Tiger and I can't boot into any cd or dvd!

    When I hold down the opion button it just reads the cd for a while and then ejects it, the only booting option i get is the HD and the same thing happens if i hold down the C key. I have tried to reset the SMC but nothing changed at all. If I let it try to boot first a folder appears with a question mark inside it, then apple logo appears for a little while (the spinning circle is nowhere to be seen) and after a few seconds i get the following text:

    hi mem tramps at 0xffe00000
    PAE enabled
    standard timeslicing quantum is 10000 us
    vm_page_bootstrap: 118136 free pages
    mig_table_max_displ ¡ 71
    Enabling XXM register save/restore and SSE/SSE2 opcodes
    12AppleACPICPU is no compatible with its superclass, 510CPU superclass changed?
    Failed to load extension com.apple.driver.AppleACPIPlatform. (This line shows in yellow)
    Couldn't alloc class "AppleACPIPlataformExpert"
    panic(cp 0 caller 0x003ABD33): Unable to find driver for this platform: "ACPI".

    Debugger called: <panic>
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0xc0ebdf8 : 0c128d0d (0x3cc65c 0xc0ebe1c 0x131f95 0x0)
    0xc0ebe38 : 0x3abd33 (x3f1398 0x2844780 0xc0ebe68 0x2851600)
    0xc0ebe58 : 0x28dace (0x2926c00 0x2823c80 0x1 0x3c106d)
    0xc0ebeb8 : 0x38f34d (0x2823c80 0x2926c00 0x29156c0 0x291c480)
    0xc0ebf38 : 0x38ebb5 (0x2823c80 0x2951600 0x8 0xffffffff)
    0xc0ebf88 : 0x3902fa (0x2823c80 0x0 0x134db9 0x390220)
    0xc0ebfc8 : 0x19b21c (0x284fd70 0x0 0x19e0b5 0x283cb70) Backtrace terminated-invalid fram pointer 0x0

    Kernel Version:
    Darwin Kernel Version 8.11.1: Wed Oct 10 18:23:28 PDT 2007: root:xnu-792.25.20~1/RELEASE_I386

    I tried too to boot into single user mode, at first it looks as though its gonna work but then i get the exact same text that i already wrote... i do not have another mac computer so i tried to creat a bootable usb but i think i wasn't succesfull at all. On my Windos Xp computer i used TransMac to format my usb into HFS+ and then i copied the files of the Ubuntu iso image to it (I also did this to another one but this time i copied the rEFIt dmg files). The usb never appeared as a boot option when i turnd my macbook in holding down option button.

    There are only two solutions that i can think of:
    -Create a bootable usb with a "live cd" vesion of a Linux distro (to recover some non-backed up files...if possible) and then create another one but this time with the tiger or leopard dvd files in it.

    -Set my computer into Target Disk mode, recover my files and then install leopard or tiger from the host computer.

    There are some limitations to this, i don't know if i am doing the correct procedure to create the bootable usb stick (If any one has any suggestions please help, i can use windows or linux to create it) and also if i use Target Disk Mode the host computer will be a G4 computer with tiger version 10.4.11 so will it work with my macbook?

    If you have anyother suggestions please post em! I am desperated (And don't want to take my computer to an apple center)

    Thanks:)
     
  2. McGiord, Jan 26, 2008
    Last edited: Jan 30, 2011

    McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #2
    I don't know if Disk Warrior or something similar could help you to recover your HDD.
    Just a thought.
    ________
    aromed vaporizer
     
  3. Props macrumors newbie

    Joined:
    Feb 16, 2008
    #3
    Hi,

    What was the problem? I have the same problem and I don´t know what to do..

    Thanks
     
  4. marconairam thread starter macrumors newbie

    marconairam

    Joined:
    Jan 26, 2008
    Location:
    Maexio City
    #4
    Problem Solved!!!

    Ok, so this is what I've done:

    First you need to get a firewire cable, any 6 pins to 6 pins cable will do.


    Ffirst insert the installation CD to the host mac (the one that is actually fine) and then shut both computers down, then plug the cable into each mac. Start first the host mac into Target Disk mode (By pushing the T key whe it is booting) and after that turn your guest computer on pushing the "option" (alt) button and you will be able to boot from the cd on the other mac, and thats basically it...the process to install your OS X from there is pretty simple. (this procedure works if you have a ppc mac and intel mac plugged in together...i actually did it this way)

    About my files...well first I started my damaged computer into Target disk mode and plugged it into the other computer (already turned on) and copied all my files from there, its pretty simple.

    The firewire cable is actually pretty cheap, i bought it at about 9 dollars because i was in a hurry, but i've seen them online at 3 dollars and i don't it would be hard to find it cheaper.

    By the way my cd drive is actually not working, so i guess i will have to buy another one


    Hope this helps, tell me how it goes
     
  5. Props macrumors newbie

    Joined:
    Feb 16, 2008
    #5
    Thanks for your reply,

    I´m confused, because I´m trying to know what the hell is bad on my laptop. I think that is a problem with the latest update (security update 2008-01), because before it everything was ok.

    I was trying and I think that is a problem with the USB´s... when I turn on my laptop without my MIDI controller /Alesis Photon x25/ and my logitech mouse, it works! but if I restart with my controller or my mouse into the USB port... kernel panic...

    So I don´t know now if is a internal problem or a software problem, It´s strange...

    Take care
     
  6. marconairam thread starter macrumors newbie

    marconairam

    Joined:
    Jan 26, 2008
    Location:
    Maexio City
    #6
    hmmmm

    I wouldn't know what the problem is. What i did to solve it was to fully restore my macbook, i formatted the HD and reinstalled the OS...

    Have you updated to the latest firmware version? may be you should wait and see if the next release will help at all?

    since when did this problem started? maybe downgrading the firmware would help, though i don't know if thats even possible in any mac (I know you can do it with the ipod, iphone or psp)...

    anyways, if anyone knows post!

    C ya
     
  7. TyrannoJack macrumors member

    Joined:
    Oct 12, 2007
    #7
    Ugh the same thing just happened to my MacBook. Is the only way to fix this a complete leopard reinstall?

    I don't have a second Mac to do that target disk stuff... Also, if I were able to get another Mac, what would happen with applications? Would they work if I put them on the new mac then transfer them back onto my reformated mac?

    Is there a way to preserve all my settings and keychain and all that?
     
  8. marconairam thread starter macrumors newbie

    marconairam

    Joined:
    Jan 26, 2008
    Location:
    Maexio City
    #8
    Don't you know anyone that has a mac? you don't necessarely have to own another mac, just use someone else's for a few hours...if you actually get your hands on another one you could get your whole "documents" folder safe from your hard disk (If it's not damaged)...usually all iLife apps store their settings in this folder (and your movies folder, music folder, ect...).

    About the apps, I guess the applications that you installed just by dragging them into your applications folder will work just fine if you take them from your HD and then put them back in your just brought-back-to-life mac, but there are some other apps that write some files and copy libraries to some other folders in your system (which is why they usually require your root password when installing)...thus they might not work if you drag them away and back into your computer. Don't you have backups of your apps?

    I don't know if the solution I posted above is the only way to fix the problem, but it certainly worked for me and it is the only method i know of. Remember, if your computer is not a year old yet you should consider taking it to apple care, they might be a little more helpfull. Also you might not necessarily have to erase all your files in your mac, you might try the method above but instead of choosing and installation method that will erase all your information (which is the one i found the most helpful for me) you might wanna try to only update (or restore/repair, if there's such and option), that way you will maybe not have to re-install your apps

    Another thing, the only reason i had to use another mac is because my mac just would't boot from my cd drive, please mae sure you have done your best to make your cd drive work (turn on and hold alt, or C or D...dunno about others...)

    Hope this helps
     

Share This Page