Macbook doesn't turn on after a smc reset

Discussion in 'MacBook' started by ChiSaw, Mar 20, 2015.

  1. ChiSaw macrumors newbie

    Joined:
    Mar 19, 2015
    #1
    Hello,

    i got a macbook (4,1, 13", early 2008) from a friend of mine with a faulty keyboard and without a battery.

    Short version:

    1) After a smc reset, the macbook doen't start with or without a battery. Also tested with and without the pram battery. Tested doing more smc resets again, didn't helped.

    2) I tested another keyboard, no reaction.

    3) Magsafe lights are working (green light and orange light).

    4) Tested to start macbook manually by shorting the two power solder points, no reaction.

    ____________________

    Long version:

    So i bought a new keyboard and a new battery. The keyboard worked fine and the Macbook started when the power when the magsafe connector was plugged in. But the battery wasn't recognized (gray X).

    So i searched a little bit and read that a smc reset could help. So i did it several times, because it didn't worked, in different variations (Hold the power button, first put battery back in and then magsafe, secondly hold down the button and put magsafe in and then the battery and so on and on).

    But on my last try of resetting the smc my Macbook doesn't turn on again. Nothing, no LCD backlight, no sound, no fans, just dead, even if the magsafe connector is plugged in. After it i tried to reset the smc again and again, but the macbook was still dead.

    But the magsafe connector show his green led, so at least not all parts of the logic board could be dead (don't know how it should be destroyed by resetting the smc).

    So i disassembled the macbook and checked the battery connector. The connections of the battery connector were not good and i cleaned them with isopropanol. Now, when i plug in the battery and magsafe it shows the orange light, that it is loading the battery, which didn't worked before. But the Macbook is still dead.

    I also tried to removed the pram battery connector for a while and plugged it in again. Nothing. I tried to start it without the pram battery, but again: nothing.

    I tried to power on manually by shorting the two solder points for power on the logic board, but no reaction. (I also tested to different topcases).

    Sorry for the long text and my bad english, but i hope that my informations could help to locate my issue.

    _______________________________

    Is there maybe something i could try or look for special chips that may blown (i guess the magsafe board is ok, because the magsafe lights are working correct?).

    It would be really nice if someone could help me.

    Christian
     
  2. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #2
    -Have you reset the ram?
    -Do you have more ram then max amount? (mine wont boot if using more then max 2g in my 1.83GHz MB)
    -Have you tryed the old PowerBook Ti red adapter fix? Power on with ac and battery removed pram battery connection and then plug connection back in...
     
  3. ChiSaw thread starter macrumors newbie

    Joined:
    Mar 19, 2015
    #3
    Thanks for your answer.

    I don't know how to reset the ram, but if you mean the pram, yes I had reset the pram. Now, this is not possible anymore, because the macbook does not start.

    I have not installed the maximum amount of ram.

    I tried the pram trick, but I can't do it completely, because the i can't get to power on the macbook.

    Does anyone know, which voltage regulator I could measure, to be sure, the voltage is correct or something like this?
     

Share This Page