Macbook EFI 1.2

Discussion in 'MacBook' started by hob, Apr 8, 2008.

  1. hob macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #1
  2. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #2
    Didn't show up for my Napa C2D MacBook. I also noticed they didn't make one for the mini. Must be a Santa Rosa thang.
     
  3. myuserid08 macrumors 6502

    Joined:
    Mar 15, 2008
    #3
    Just updated my macbook to 1.2
    Says it helps with reliability, not that I had a problem in the first place. All the bugs I have are leopard os related.
     
  4. John01021988 macrumors 6502

    Joined:
    May 11, 2007
    #4
    Is not Santa Rosa related I think..... Many users with non-SR have updated successfully. I cannot update my firmware by some reason...
     
  5. DaBrain macrumors 65816

    DaBrain

    Joined:
    Feb 28, 2007
    Location:
    ERIE, PA
  6. rwskemer macrumors regular

    Joined:
    Feb 18, 2008
    #6
    I may have experienced a problem with the EFI 1.2 update on my MacBook. After I performed the update I began to hear a static-like sound and a sound that is very similar to the CPU whine that I would hear in the Dell XPS M1330. The sound emanates from the upper left hand corner of the keyboard.

    I realized I was hearing this sound actually before the firmware updates were installed. Me, still being a Mac novice, at least as far as firmware updates are concerned, didn't realize I had to shutdown and press the power button until the loud sound played to actually install the firmware.

    Maybe it's me, I do have ridiculous hearing that makes me go insane sometimes. Has anybody else heard anything weird on their MacBooks? This probably has nothing to do with the firmware updates, I just realized it while it was being installed...
     
  7. vansouza macrumors 68000

    vansouza

    Joined:
    Mar 28, 2006
    Location:
    West Plains, MO USA Earth
    #7
    worked on my two iMacs but not on my MBP or my new MB.
     
  8. myuserid08 macrumors 6502

    Joined:
    Mar 15, 2008
    #8
    Mines a Santa Rosa macbook.
     
  9. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #9
    Installed here. No idea exactly what issues its supposed to resolve, especially since I didn't have any problems before (and Apple's being their usual vague self when it comes to the content of such updates), but so far I haven't seen any differences -- which I guess is a good thing.
     
  10. gkarris macrumors 604

    gkarris

    Joined:
    Dec 31, 2004
    Location:
    "No escape from Reality..."
    #10
    My MacBook runs tons faster and apps load much faster when using 4 Gig...
     
  11. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #11
    any reason why my software update would not show this on my macbook? I have the MB from late last summer, the one right before the SR update.
     
  12. macrack macrumors newbie

    Joined:
    Mar 27, 2008
    #12
    Not sure what this update really did, but I am able to watch a utube video without going heating up into full fan mode. Tried various vids and never got the maxed out fan situation. This is new for me. Anyone else with this result?
     
  13. ShiggyMiyamoto macrumors 6502a

    ShiggyMiyamoto

    Joined:
    Mar 29, 2004
    Location:
    Just outside Boston, MA.
    #13
    Issues...

    Okay, so a few nights back, I saw on MR that some new EFI firmware for MacBooks (all types) was released. I get it, install it on my 2.2 GHz MacBook, and everything worked fine. Then today (yesterday, since it's past midnight) I used it at work pre-shift, and it was still working fine. I let my friend/coworker Heather use it to look **** up on MySpace. Another coworker arrived (a huge BSD fan) and I wanted to show him the console mode of OS X. I set the Accounts pref pane to show username and pw on login so I can drop into >console mode. After I was tired of playing with that, I set it back to normal.

    A few minutes pass, and then we all had to get to what's called the small training room to start our shift (we're graduating trainees so to speak). I close it, bag it, and go the the room. I then open it up and I had Terminal.app open. Then I close it again to put it away, as I can't use it other than on a break. Then, at 5:30pm, the first break, I take it out and it won't boot, or that's how it seems. I think what happened was that somehow the contents of memory weren't saved to memory, and the firmware got confused or something. I know of the firmware restoration disc, but out of desperation I popped in my Install DVD to make sure it wasn't a logic board issue, which it isn't, since the disc spins up fine.

    And yes, I've tried resetting the PMU (SMC really as it's called on Intel Macs) and it's a no go. So right now my MB is "comatose". I can't get the install DVD out to follow Apple's steps on how to use the restoration utility that my friend burned to CD for me. Any ideas on how to eject the disc? I've tired the normal methods, i.e. eject key, mouse button pressed on start up, etc.

    Thanks in advance,
    ShiggyMiyamoto
     

Share This Page