Macbook eject key not working?

Discussion in 'MacBook Pro' started by winstano, Feb 3, 2008.

  1. winstano macrumors regular

    Joined:
    Dec 17, 2005
    #1
    My gf bought a MacBook a few weeks back, and for some reason the eject key isn't working properly. (Core 2 Duo running Leopard)

    When you hit ctrl and eject, we still get the "Are you sure you want to shut down your computer now?" dialogue box, but when you just hold eject to get a CD out, nothing happens, not even the eject square in the middle..

    Is there a setting that's been unticked somewhere? Or is this something that needs a genius bar attention? (I've tried relaunching the Finder and repairing permissions)
     
  2. chrisgohcs macrumors member

    chrisgohcs

    Joined:
    Nov 10, 2007
  3. DMC-12 macrumors 6502

    DMC-12

    Joined:
    May 16, 2007
    Location:
    Nashville, TN
    #3
    My Leopard-running SR 2.2 GHz MacBook just arrived, and I'm experiencing something similar I guess. The eject key doesn't cause the drive to eject until about the second firm press of the eject key. I kind of like this though because it means the drive won't eject accidentally if I miss the delete key.

    As for the accidental caps lock protection, I CAN'T STAND IT. I constantly have to backspace over mis-capitalized words and tap the caps lock key multiple times.
     
  4. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #4
    Make sure to hold the eject key for about a second - it has a delay on it so a quick (accidental) tap when reaching for Delete or Volume Up wont pop your disc out.

    The caps lock key on the Santa Rosa MacBooks also has a slight delay on the caps lock key to prevent accidental activation. Personally I like it. The new slim aluminum keyboards also have this slight delay.
     
  5. winstano thread starter macrumors regular

    Joined:
    Dec 17, 2005
    #5
    We've tried option + Esc, to no avail. I'm aware of the delay on the eject key (Own a G5 and a MB myself), but this MB is different to mine in that it has the Leopard Specific keyboard (With the spaces logos etc on the Fn keys)...

    Does anyone have any idea why this would be happening? I'm really confused as to why it would recognise the eject key when you hit Ctrl but not when you hold it on its own?
     
  6. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
  7. Santino macrumors newbie

    Joined:
    Oct 13, 2010
    Location:
    Florence, Italy
    #7
    just checking if the OP found the solution, I'm having the same problem
     

Share This Page