MacBook External Display Problem

Discussion in 'Mac Basics and Help' started by Thunderfm, Mar 4, 2009.

  1. Thunderfm macrumors newbie

    Joined:
    Mar 4, 2009
    #1
    Ok here we go...

    I am running a MacBook 2.16 intel on Leopard 10.5.6

    Just updated to 10.5.6 today and it all went horribly wrong.

    I've managed to fix most of it apart from one biggy.

    I'm running 2 external displays. One on the Mini-DVI and one via USB with a Tritton adapter. Trouble has arised when my MacBook tries to detect the displays and for some reason thinks there are 8 of them (including the MacBook display). With 10.5.5 everything worked flawlessly but now its all down the pan. I have tried it without any external displays just in case it was the USB that was shaking things up but even with one screen it still thinks there are 8. Anyone know how to get this thing to believe it only has the number of screens that are really there??? Detect displays does nothing, plugging in and out doesn't work and the good 'ol turn it off and on again does nothing either!

    Please Help!!!!
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I'm not familiar with that USB-video adapter, but does it have a driver (I assume so), and if so, did you try completely removing the driver or just unplugging the adapter itself?

    If it does have a driver and you didn't remove it, it's entirely possible (likely, even) that it's what's causing the phantom screens. If removing the driver fixes it, try reinstalling and see if that helps; if not, you could try either finding where it stores its systemwide prefs and delete them (in case that's what's screwed up), or it could just be a bug between their system and 10.5.6--there were some significant changes made in it that could have broken the thing. If so, you'll just have to wait for them to update the driver.

    Now, if removing their driver doesn't fix it, or it doesn't require one, then there's obviously something else going on. Your most likely fix in that case would be to just do an archive and install of the whole OS, though it's possible locating and removing the relevant system preference would fix it.
     

Share This Page