Macbook failure! Any help would be appriciated.

Discussion in 'MacBook Pro' started by coreyweb, Oct 9, 2007.

  1. coreyweb macrumors newbie

    Joined:
    May 15, 2007
    #1
    Hello,

    I'm so angry and depressed. I've had my macbook for about.... 2 months. And it completely screwed up on me last weekend. You see, all I did was shut it down. And later in the day when I tried turning it on again, it brought me to the white Apple logo screen with the spinner and just spun for like 6 or 7 minutes then the screen went black and command point, binary, etc. came up.

    Losts of other people apparently have had this problem....but I've tried like EVERYTHING and it hasn't worked. Can ANYONE help me??

    I called Apple and the guy sayed it was a "directory" issue.

    The most important thing..... I really want to save some files from my computer... is there any way?? I want to save my documents and few Garageband files. Those are the most important.

    Is there any way that I can save them?? ANY help would be SO appriciated.
     
  2. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #2
    Stick the Recovery DVD in the drive and run Disk Utility/First Aid/Repair Disk

    Though Apple does have a helpful My MacBook won't start section at www.apple.com/support

    Edit: they used to, cannot find it quick. but there is a routine they have to run through to try to get around startup crashing issues.
     
  3. coreyweb thread starter macrumors newbie

    Joined:
    May 15, 2007
    #3
    I tried that......it errors when I try and repair.

    I tried resetting the PRAM or whatever,

    I tried resetting the power management...

    I tried everything on the apple support site...
     
  4. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #4
    First step: Run Disk Utility on the drive from the install disk that came with your computer. In case you don't know how (sounds like you're new to Mac, sorry if that's not the case), put the disk in the drive, then boot up the computer with the C key held down until you see the grey screen with the Apple logo. It should boot into the installer, but instead of going through any of the steps you see there, go up to the menubar and click on (I believe) the Tools menu, then Disk Utility. Click on your hard drive on the left, then on the right click Repair Permissions and then Repair Disk. If it comes up with errors that it says it fixed, run it one more time to make sure, then restart and see if everything works.
    EDIT: Got beaten to this step, continue from here.

    Second step: Assuming that didn't work, do an Archive and Install. Start up from that same disk, go through the steps up to where you choose which drive to install onto. Click on your hard drive, then at the bottom, click options. Choose the Archive and Install option, including the checkbox that is under that which specifies to Preserve Users and Network Settings. Then proceed through the installation as normal. After it's done, all of your user files (anything you use for the most part) should be intact, and the old System folder will be placed in a folder labeled Previous Systems. If everything works properly and you know you don't have anything from there you need (usually only globally installed Application Enhancers and a few preferences), then you can safely trash that folder.

    Third step: If all that fails, take it to a Mac dealer (not an Apple Store, they generally don't guarantee not to wipe your data if they don't feel they can do anything with it easily) and see if they can just run DiskWarrior or a similar tool and get it working again. For that matter, purchasing and running DiskWarrior yourself isn't a bad option. It fixes most issues that are directory related, if the previous options didn't work.

    Regardless of which idea fixes the problem (assuming one of them does), your next step should be to purchase an external hard drive of some type if you don't already have one, and back up your files! Can't stress that enough. Always, always back up your files.

    jW
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
  6. coreyweb thread starter macrumors newbie

    Joined:
    May 15, 2007
    #6
    Thanks for your help

    Ya I tried most of those things too.

    I tried doing an archive install, but it wouldn't work. I'd get an error message.

    I took it to my tech. place on campus and I think he might have run diskwarrior. Not sure though. I don't think I have money for diskwarrior myself though....

    You really think running Diskwarrior or something similar will help??

    I tried using Tech tools deluxe that I got with my Applecare plan...but it wouldn't boot in from the CD.
     
  7. coreyweb thread starter macrumors newbie

    Joined:
    May 15, 2007
    #7
    Third party ram??

    But why would that be the problem?

    The system profile from the install disk says it reads it fine.

    I got a set from Crucial.
     
  8. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #8
    Sometimes marginal RAM will test fine, but corrupt the HD.

    If it isn't the HD itself that is going bad.

    But removing the RAM eliminates something from the equation. Especially if it crashing into a text screen which is usually a kernel panic. And most of those are RAM related.

    Note: Most of those should be caught by the computer, but if it is crashing really hard and missing the screens and dropping into text. That is the going to give you an indication of where the problem is.

    though if you can see the HD with the DVD in the drive. Looking at the panic log may be helpful.
     
  9. coreyweb thread starter macrumors newbie

    Joined:
    May 15, 2007
    #9
    But how can I remove the RAM and still run my comuter?? Doesn't it have to have it in it to run. I could take out one...but both??
     
  10. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #10
    Searching for the Panic Log file would be the most helpful, if you can.

    Should be at

    Macintosh HD/Library/Logs/panic.log

    Though the machine's crash into the text screen will likely say the same thing.

    If you can get access to the drive.

    Should get something that looks like this ATI driver one...
    Code:
    Sun Sep 30 15:14:46 2007
    panic(cpu 0 caller 0x001A4A55): Unresolved kernel trap (CPU 0, Type 14=page fault), registers:
    CR0: 0x80010033, CR2: 0x0000004d, CR3: 0x01895000, CR4: 0x000006e0
    EAX: 0x00000001, EBX: 0x2ffd30a0, ECX: 0x00000001, EDX: 0x3003403c
    CR2: 0x0000004d, EBP: 0x25e53c08, ESI: 0x2ffd3100, EDI: 0x3f715000
    EFL: 0x00010202, EIP: 0x45482231, CS:  0x00000008, DS:  0x2ffd0010
    
    Backtrace, Format - Frame : Return Address (4 potential args on stack) 
    0x25e539b8 : 0x128d08 (0x3cc0ec 0x25e539dc 0x131de5 0x0) 
    0x25e539f8 : 0x1a4a55 (0x3d2524 0x0 0xe 0x3d1d48) 
    0x25e53b08 : 0x19aeb4 (0x25e53b20 0x63dce00 0x25e53b68 0x4547bbb1) 
    0x25e53c08 : 0x4547a3b4 (0x3f715000 0x25e53c28 0x25e53c58 0x3f715168) 
    0x25e53c58 : 0x4545c37a (0x3f715000 0x25e53cd0 0x0 0x0) 
    0x25e53cf8 : 0x3b1449 (0x3f715000 0x1 0x25e53d2c 0x25e53d28) 
    0x25e53d38 : 0x3b4905 (0x3f715000 0x1 0x6425890 0x1) 
    0x25e53d68 : 0x189db1 (0x3f715000 0x1 0x6425890 0x4895fc0) 
    0x25e53db8 : 0x12b4c3 (0x4895f8c 0x48903a0 0x25e53df8 0x11e042) 
    0x25e53df8 : 0x124b17 (0x4895f00 0x439adc0 0x6453cc4 0x0) 
    0x25e53f08 : 0x195a42 (0x25e53f44 0x0 0x0 0x0) 
    0x25e53fc8 : 0x19b32e (0x4e39180 0x0 0x19e0b5 0x4e3a220) No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xbfffe158
          Kernel loadable modules in backtrace (with dependencies):
             com.apple.ATIRadeonX2000(5.0.4)@0x45453000
                dependency: com.apple.iokit.IOPCIFamily(2.2)@0x35e63000
                dependency: com.apple.iokit.IOGraphicsFamily(1.4.7)@0x45278000
                dependency: com.apple.iokit.IONDRVSupport(1.4.7)@0x45293000
    
    Kernel version:
    Darwin Kernel Version 8.10.3: Wed Jun 27 23:29:36 PDT 2007; root:xnu-792.23.3~1/RELEASE_I386
    
    
    *********
     
  11. ab2650 macrumors 6502a

    Joined:
    Jun 21, 2007
    #11
    You don't have the original memory that came with your MB? What Sun Baked is telling you is return the system to it's original state when you bought it; Remove your new ram and put back (if you removed) your OEM ram.

    You're right that it won't run with nothing in the ram slots - don't do that.
     
  12. coreyweb thread starter macrumors newbie

    Joined:
    May 15, 2007
    #12
    Hey,

    Ya I do have the original RAM, but not with my on campus its at my home three hours from here.

    Do you really think this would resolve the issue??

    The panic log that came up on screen read:

    bad system call
    respawning to fast, throttling!
    restart in 10 seconds
    too many failures in succession

    Would changing the RAM help if the Apple guy was right and it was a directory issue??
     
  13. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #13
    If you can't boot from the Tech Tool CD, then you have a hardware problem, almost certainly bad RAM. If you also have access to DiskWarrior, it would not hurt to try to boot on that CD, but this seems unlikely to work. You might also try booting into Single User Mode and running fsck. Here's how:

    Restart with the cmd-s keys held down, until you see a black screen with white characters. After the text stops scrolling, at the command prompt, type:

    fsck -f [including the space, return]

    If any repairs are reported, run fsck again until none are reported. Then, at the command prompt, type:

    reboot [return]

    If this does not work, you'll need to try the advice given previously to restore the RAM to its original configuration.
     
  14. TheStu macrumors 65816

    Joined:
    Aug 20, 2006
    Location:
    Carlisle, PA
    #14
    Definitely drop the old RAM in there to see whats what. RAM can cause all kinds of issues on computers, you simply would not believe, so as soon as you can, get your old RAM and put it in there. If the problem goes away, call up Crucial (or did you say Corsair?) and get a new set. Almost all the makers have lifetime guarantees, so it might at worst cost you shipping, but maybe not even that.

    I saved the RAM from my MacBook for about a year after I put in my 1GB kit, just to be safe, glad to hear that you save yours as well.
     
  15. coreyweb thread starter macrumors newbie

    Joined:
    May 15, 2007
    #15
    Hey guys,

    Thanks so much for all the help.

    I tried booting into it with command S...

    it brought the black screen and white text. But when it gets done it won't let me type anything in let alone fsk or whatever.

    The last thing it says is "CSRHIDTransitionDriver: : probe booting in single user .. do not match"

    (edit: like 5 minutes after I thought it was done with the above it says this now:
    "disk0s2 : 0xe0030003 (UNDEFINED).
    jnl : update_fs_block: failed to update block.
    jnl : journal_open: error replaying the journal. hfs : early jnl init: failed to open/create the journal (retval 0)"

    That doesn't sound good.

    Then the command prompt bare, but its not blinking and I can't type anything.

    So the RAM huh? The RAM could be the culprit. Dang.... and just by putting the original ram in it would fix it??

    Well I'm going home this next weekend so I guess I'll try the original RAM. But wouldn't the Apple guy suggest that?? (duh, I guess I didn't tell him I got other RAM)....but wouldn't he suggest something about it being a RAM problem?

    I sure hope I can find SOMETHING that works. I knew I should have backed up....I was planning on doing that when leapord comes out. I figured my computer could last a month....but alas! Aparrantly not.

    I think I'll try booting into Tech Tool Deluxe one more time.... its the same as the installer right?? put the CD in and hold C??
     
  16. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #16
    Right, hold down the "C" key.

    If you've upgraded the RAM, and it's at fault, then you should not blame the MacBook. Let us know how it goes after you swap back to the original RAM.
     
  17. macbookfailure macrumors newbie

    Joined:
    Dec 3, 2007
    #17
    Apple has been made aware of a high number of hard drive failures in the MacBook but they refuse to take action.

    macbookfailure.blogspot.com
     

Share This Page