Macbook fan exhaust always high

Discussion in 'MacBook' started by LouderIsBetter, Jun 28, 2010.

  1. LouderIsBetter macrumors newbie

    Joined:
    Jun 28, 2010
    #1
    For a while now, the fan exhaust on my macbook has been constantly rising past 6,000rpm when I'm simply watching a YouTube video or even just listening to iTunes alone.

    I've of course googled this problem and found that many others with this problem solve it by taking a look at Activity Monitor and end a process they didn't realize was using much of the CPU. When I tried this I found that Activity Monitor was actually taking up the most power as it was the only application open and it was only using 0.5-1.0% of the CPU.

    Also when I try to watch a video on YouTube or any other site for that matter, the macbook heats up instantly, the fan reaches it's max, and the computer itself becomes very glitchy (mouse pointer skipping all over, delayed actions, etc.)

    As you can imagine this has been extremely frustrating, as it hinders what I can and can't do, from basically surfing the web to watching a video online. Any and all help is extremely appreciated; I just can't figure this one out!
     
  2. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #2
    I just want to add that the fans run full-out almost constantly. Only when I have nothing opened or running, and after leaving it alone for about 10 minutes, will it start to calm down.

    Also the skipping and delayed actions (such as dashboard being very choppy as it fades in and out, and the mouse pointer skipping) only happen when a video is running. I suspected that my video card can't handle it, but they're usually little standard definition, three-minute long videos, nothing too long or HD.
     
  3. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #3
    Choppy actions sound like you CPU is overheating and taking steps to protect itself (IIRC it lowers its clock speed). So the behaviour does not sound normal

    Try resetting your SMC (google Mac SMC Reset, Apple site will tell you how). SMC controls some aspects of the fan.

    But I suspect you have a bigger problem in your cooling system - perhaps dust in the fan vents or another blockage.

    Download iStat Pro and post your temperatures (of all components, particularly the heatsink/s, not just the CPU) and fan speed when your Mac is completely idle ie CPU is at 1% or less. Then repeat when the Mac is working hard and glitching.

    Then post the temps on here and we will try to diagnose.
     
  4. bob.loblaw macrumors member

    Joined:
    Feb 26, 2010
    #4
    Check to see if you have a print job that is hung up.
     
  5. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #5
    I actually found that a lot of people fixed the problem with the print job tip, but I've got nothing going; but thanks!

    I have iStat Pro but how do I capture an image of it? Activity Monitor as well?
     
  6. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #6
    http://graphicssoft.about.com/od/screencapturemac/ht/macscreenshot.htm

    option 3 works well for iStat, just grab the bit that has temperature on it and post on here.
     
  7. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #7
    Ok thanks, I got it. This is with one Safari window open..
     

    Attached Files:

  8. bob.loblaw macrumors member

    Joined:
    Feb 26, 2010
    #8
    Can you post a shot of Activity Monitor sorted by %CPU?
     
  9. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #9
    Yeah, this is my Activity monitor with Safari as the only other application running.
     

    Attached Files:

  10. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #10
    I suspect you have a blocked air path for the fan. Here's some thinking out loud, others feel free to pitch in.
    NB I assume you have an older model (pre-unibody) MB. The iStat readings look like it. Please correct me if I'm wrong!

    What possibilities do we have....

    1. CPU working very hard, running hot. REJECT. CPU is idle. CPU is also fairly cool but not as cool as I'd expect with a 6200 rpm fan - see later.

    2. GPU/Northbridge working very hard. REJECT. GPU is not very hot.

    3. bad thermal contact between CPU and heatsink. REJECT. Only 4 C difference, at idle, consistent with other MBs/MBPs I've seen. (NB this also confirms your CPU is idle, a hard working CPU has > 20 C difference between CPU and heatsink)

    4. bad thermal contact between heatsink and outside air - PLAUSIBLE. The heatsinks are very hot for an idle Mac with fans at 6200 rpm. And so is the CPU. At idle the CPU dissipates just a few Watts. They have the kind of temperature I would expect to see for a Mac with a CPU working quite hard. For example, my 2006 MB under full CPU load has the CPU at about 90 C, the heatsink at about 70 C, and the fan at about 4000 rpm. Your heatsink is > 60 C at CPU idle. I think that's wrong. I also think the heat from the CPU is soaking into the Mac rather than getting pulled into the outside air - your HD and enclosure base look quite warm for an idle MB.

    So I think you have a blocked air path. Some things to check
    - When your fan is running at 6200 rpm you should feel a strong air flow coming out of the hinge. Do you? When the CPU is running at full speed this air should be HOT on the back of your knuckles
    - Watch iStat when your Mac is glitching. Do you see the CPU temperature go >105 C, then drop back down, then repeat? If so that's a sign of bad cooling, Intel's safety mechanism is down clocking the CPU. (NB for some older CoreDuos & Core2Duos this magic temperature might be 95 C not 105 C.)
    - when your Mac is glitching, what are the internal temperatures (you could post iStat again if you can do it while glitching)

    This thread might be worth a read. It's related to an MBP but some similar analysis...
    http://forums.macrumors.com/showthread.php?t=887619

    Solution? If I'm right it might be as simple as putting a vacuum cleaner on the fan outlet and sucking out the fluff (Google it first!) or taking the back off and having a look. You might want to post another thread asking for advice. But wait for a bit and see if any other readers have any better ideas!
     
  11. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #11
    Have a look at Activity Monitor (Applications > Utilities) and select Show All Processes and sort by CPU to see what the culprit may be.

    image below uses sorting by CPU as an example
    [​IMG]



    Have you reset the SMC yet, as proposed by Pax?

    Intel-based Macs: Resetting the System Management Controller (SMC)
     
  12. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #12
    I tried resetting the SMC, but it didn't help.

    Here's my iStat and Activity Monitor (all processes) when it's glitchy.
     

    Attached Files:

  13. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #13
    And the culprit is FLASH and Safari.

    See the first entries?

    [​IMG]
     
  14. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #14
    Yeah, that was while a YouTube video was playing, that's the only time it glitches.
     
  15. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #15
    Either use the HTML5 beta of YouTube or ClickToFlash if you don't want to use Flash.

    Flash is a very welcome application in the Mac OS X community, as it is one of the few programs to actually use as much CPU as it can get, depending on the size and complexity of the source though.

    In all seriousness, Flash is a CPU hog and badly programmed for Mac OS X.
    Use MRoogle to find thousand of love/hate threads about Flash on Mac OS X.
     
  16. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #16
    That makes sense, it's just that I don't understand why it would start acting that way randomly. I used to be able to watch YouTube videos before without any problems, but now I can't even watch one all the way through.
     
  17. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #17
    Maybe you watch them in HD (720p) now, and before you just watched them in 280p/360p/480p or whatever YouTube calls those.
     
  18. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
  19. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #19
    YouTube changed something a-while-ago-back (that's a technical term) with the encoding, I think it was around the time they started offering HD, that negatively affected PowerPC users, I don't know what effect it had on Intel CPUs but the smoothness of the video playback as well as the audio/video syncing has really been FUBAR since they made the change. Oh yeah, and it really maxes out this old PowerPC G4 processor.
     
  20. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #20
    Well aside from YouTube, the fans still reach their max exhaust all the time, for no apparent reason.
     
  21. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  22. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #22
    I don't think Flash/YouTube is the only culprit, I still think there is a hardware problem.
    - If you look at the OP's post 7 his fans were at 6204 even with CPU at 65 C. I suspect that's not Flash
    - In his latest post the fans are at 6188 rpm when the CPU is at 82 C. I've never seen a "well behaved" Mac with its fans so high, even gaming. I would expect to see 3000-4000 rpm playing Flash.
    - the delta-T between CPU and heatsink is only about 10 C. If the CPU was really maxed out it would be consuming 25 W and I'd expect a delta-T of 20-25 C, like other Macs I've seen. So the CPU isn't working hard enough to justify 6188 rpm.

    OP - can you try the following and post iStat temps both times

    (a) when the computer is idle (eg reboot it and don't open any programs, leave it for 5 mins then take the iStat snapshots. CPU should be at 1-2%). I know you did this in post 7 but your computer might not have been completely idle then
    (b) from idle open Terminal and type "yes > /dev/null" without the quotes and hit return. This will load up 1 CPU core. In Activity Monitor you should see 1 core working hard, the other nearly idle. Leave the computer 5 minutes & then take a snapshot.

    Does (b) cause glitching? (It shouldn't)

    Oh, and can you post your exact MB model & CPU speed. Then we can look up the Intel specs and its max safe temperature.

    Sorry to give you such a long "shopping list". But I think Flash is a red herring, it would be good to check it out.
     
  23. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #23
    Thanks so much for everyone's help btw.

    I have a white 2Ghz Core2Duo MacBook: 320GB WD Scorpio HD(updated), 2GB RAM(updated). I'm not sure what model it is exactly, it was purchased new in January 2007 if that helps.

    Here are the two iStat shots and a shot of activity monitor while "yes" was running. (Sorry, I don't know how to post pictures directly into a post, can anyone help with that too?)
     

    Attached Files:

  24. Jason Beck macrumors 68000

    Jason Beck

    Joined:
    Oct 19, 2009
    Location:
    Cedar City, Utah
  25. LouderIsBetter thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #25
    If you read a couple posts earlier, PAX asked me to open terminal and start that process.
     

Share This Page