Macbook + flashing question mark + unable to boot on install dvd

Discussion in 'MacBook' started by pvermaer, Jul 25, 2009.

  1. pvermaer macrumors newbie

    Jul 25, 2009
    Hi folks,

    I'm having a problem with my mid-2007 white macbook (2.16, 120gb, 512).

    A few days ago I was burning a DVD with iDVD and for some reason my MB stalled, and the screen went black. When I rebooted all I could hear is my HD ticking and a flashing question mark in a box. So obvious explanation is my HD is resting in peace. I wasn't able to boot from the install DVD. Couldn't zap RAM etc so the boot key commands didn't work.

    So I bought a new HD (WD Scorpio Blue 320gb SATAII) and placed it in my MB, boot it up and... still the same problem (chime -> grey screen -> long time -> very long time -> folder with flashing question mark). Unable to boot from DVD.

    Anyone have had a similar issue? Any advice?
    Should I give it to Apple and let them fix it (probably really expensive?)

    Thanks in advance! Hope the mac-community can come up with a solution.

    PS: I know there's lots of threads about the flashing question marks but most of them can fix it with a new HD + install DVD and that's not the case with me.
  2. myuserid08 macrumors 6502

    Mar 15, 2008
    Were you keeping the "c" button pressed down during boot?
    Even if the hard drive is faulty it should still boot from the DVD, could be a logic board issue.
  3. pvermaer thread starter macrumors newbie

    Jul 25, 2009

    thanks for the reply!

    I've solved the problem. There seemed to be a problem with the open firmware password that made all the key commands not work.

    So problem solver: if you have an EFI-password set, make sure you press Alt just before the grey screen shows up and after you've given in your open firmware password, you can install OS X.

Share This Page