Macbook freezes on Start-Up

Discussion in 'macOS' started by AppleSingh, Jan 30, 2008.

  1. AppleSingh macrumors newbie

    Joined:
    Oct 26, 2007
    #1
    Hello All,

    I am running Mac OS X 10.5.1 on a Macbook Core 2 Duo 2.16 with 4 gb ram. The other day, my mac froze while in screensaver mode, so i turned it off.

    When I went to turn it back on, it stayed on the Apple logo screen for a while with the circle turning under it, and after 5 or so minutes it just restarts.

    I have tried clearing the PRAM with no results. When I go to startup disk mode, my start up disk DOES appear.

    I popped in my leopard disc and figured Id try an archive and install, but when I try to install, the HD has a yellow triangle with an exclamation point in it. When I choose to install it there, it says I need to change the installation settings, but the only installation setting that is available is to erase everything.

    Does anyone know how I can solve this problem?

    Any help is appreciated.

    Thanks in advance!
     
  2. The Stig macrumors 6502a

    The Stig

    Joined:
    Nov 4, 2006
    Location:
    On the track
    #2
    The same thing happened to me a couple of weeks ago, but my froze while logging out and it didn't reboot after a couple of minutes staying on the Apple log.

    What I ended up doing was formating and then restoring from my time machine backup... which took almost 4 hours, but it worked and I haven't had a problem since.

    If you don't have a time machine backup... You might be SOL. Doing the time machine backup to me was one of the last options.

    If you don't have a Time Machine backup. Try:

    1. Fresh format and fresh install of 10.5
    2. Fresh format and fresh install of 10.4 and then upgrade or fresh install 10.5 after 10.4 is working.

    Let me know how you make you.

    The Stig
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #3
    With Leopard disk, did you

    Repair Permissions?
    Repair Disk?
     
  4. The Stig macrumors 6502a

    The Stig

    Joined:
    Nov 4, 2006
    Location:
    On the track
    #4
    For Sure. Right to ran a repair on anything and everything. What do you have to lose?

    The Stig
     
  5. AppleSingh thread starter macrumors newbie

    Joined:
    Oct 26, 2007
    #5
    Took me a couple days, but I finally fixed this darn problem.

    Here's what I did.

    I popped in the leopard disk to try and do a disk repair. That option wasn't available, but verify disk was. So I tried to verify the disk, and got this error.

    "Invalid Sibling Link"

    I google that error to see what the solutions one. Apparently if you go into Single User mode you can force your Mac to do the repair, which is what I did.

    After unmounting the drive, I used the command
    Code:
    fsck_hfs -r /dev/disk0s2
    The first time I tried this, there were a whole bunch of errors, and eventually it said, "After three attempts, the disk was unable to be repaired."

    Reading up more on the situation, I found out that if I ran it again everything should be ok. I did this and it worked flawlessly. My Mac was up and running, slow however. I backed up everything and did a clean install.

    Hope this helps anyone else who may have had this problem.
     
  6. erikpmort macrumors regular

    erikpmort

    Joined:
    Oct 4, 2006
    #6
    wow nice job.. sounded pretty technical. I have had a problem similar to that before as well but sent it in.
     

Share This Page