Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

SethBoy

macrumors regular
Original poster
Jun 23, 2007
217
632
I put my MacBook to sleep about 1AM and went to bed. Used it for a while at around 9AM+, put it to sleep by closing the lid and brought it to work. When I took it out from its case from my backpack, it was super hot, presumably because it was running and there is no ventilation in its carrying case. The battery dropped from 100% to 71%.

Below is the wake log… Any ideas how to prevent it from waking during its sleep?

Things like wake on WiFi access and allow Bluetooth devices to wake the Mac have been turned off. Mac was used as a fresh computer with just photos and other media transferred to it (ie. not restored from a backup).


Jun 6 00:07:50 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Button (0x03)

Jun 6 01:29:48 Seths-MacBook kernel[0] <Notice>: Wake reason: RTC (Alarm)

Jun 6 03:29:44 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 03:30:14 Seths-MacBook kernel[0] <Notice>: Wake reason: RTC (Alarm)

Jun 6 03:50:05 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 03:50:18 Seths-MacBook kernel[0] <Notice>: Wake reason: EC.SleepTimer (SleepTimer)

Jun 6 04:29:49 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 06:30:18 Seths-MacBook kernel[0] <Notice>: Wake reason: ?

Jun 6 06:30:18 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 06:30:19 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 08:30:38 Seths-MacBook kernel[0] <Notice>: Wake reason: ?

Jun 6 08:30:38 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 08:30:39 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 09:24:56 Seths-MacBook kernel[0] <Notice>: Wake reason: EC.DarkPME (User)

Jun 6 09:24:56 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 09:24:57 Seths-MacBook kernel[0] <Notice>: Wake reason: EC.DarkPME EC.ACAttach

Jun 6 09:24:57 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 11:50:11 localhost kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 11:54:24 Seths-MacBook kernel[0] <Notice>: Wake reason: EC.PowerButton (User)

Jun 6 11:54:24 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)

Jun 6 11:54:25 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService:: processWakeReason Wake reason: Host (0x01)​
 
Last edited:

Gav2k

macrumors G3
Jul 24, 2009
9,216
1,608
Turn wake for network access off in the system settings. Bonjour is waking your Mac.
 

SethBoy

macrumors regular
Original poster
Jun 23, 2007
217
632
Turn wake for network access off in the system settings. Bonjour is waking your Mac.

You mean this option right? It’s already turned off.
ECSPWsd.png
 

Gav2k

macrumors G3
Jul 24, 2009
9,216
1,608
You mean this option right? It’s already turned off.
ECSPWsd.png
That's strange then as it all points towards a network wake with exception of the button presses to manually wake the machine.
 

SethBoy

macrumors regular
Original poster
Jun 23, 2007
217
632
That's strange then as it all points towards a network wake with exception of the button presses to manually wake the machine.

Even stranger is that between 9:30AM to 11:50AM, it didn’t seem to wake up, but it was super hot to the touch and it lost 30% of the battery life.
 

where is it

macrumors 6502
Jun 19, 2012
429
282
England
Did you click on the Battery tab in the Energy Saver preferences to check the Power nap checkbox is off?
The screen shot shows the Power adaptor pane.
Presumably your MB isn't on charge in your back pack.
[doublepost=1465202088][/doublepost]Another thought - You haven't got any weird magnets, Apple Watch or anything like that hanging around in close proximity to the MB by any chance?

Anything magnetic could possibly confuse the lid close function and maybe make your MB think it's open and ready for business. It's a stretch though.
 

Bonaqua

macrumors member
Jan 10, 2014
58
8
Sounds like stuff that has plaguing every mobile skylake product since launch. Last time I checked the surface products are still suffering from sleep/wake issues.
 

SethBoy

macrumors regular
Original poster
Jun 23, 2007
217
632
I had this happen to me awhile ago - on the energy saver screen click restore defaults and then set your preferences again.. Was what eventually solved it for me.

Alright thank! Will try and report back on whether it works.

[doublepost=1465216848][/doublepost]
Did you click on the Battery tab in the Energy Saver preferences to check the Power nap checkbox is off?
The screen shot shows the Power adaptor pane.
Presumably your MB isn't on charge in your back pack.
[doublepost=1465202088][/doublepost]Another thought - You haven't got any weird magnets, Apple Watch or anything like that hanging around in close proximity to the MB by any chance?

Anything magnetic could possibly confuse the lid close function and maybe make your MB think it's open and ready for business. It's a stretch though.

I have turned off Power Nap for both. I do carry it with the Magic Mouse in the side pocket of the case… Hmmm.
 

SethBoy

macrumors regular
Original poster
Jun 23, 2007
217
632
This issue of being very hot in its sleep and losing battery charge also happened one other time when I brought my MacBook to a friend’s home. I’m guessing that it wakes up when it is moved to a location where there is a different known WiFi network during its sleep.

Last night, MacBook was left to sleep on battery power, and it remained at 100% this morning. That’s good I guess, but it still seems to wake up every 1 or 2 hours.



Jun 7 02:30:28 Seths-MacBook kernel[0] <Notice>: Wake reason: RTC (Alarm)

Jun 7 04:30:25 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

Jun 7 04:31:36 Seths-MacBook kernel[0] <Notice>: Wake reason: EC.SleepTimer (SleepTimer)

Jun 7 05:30:28 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

Jun 7 07:31:04 Seths-MacBook kernel[0] <Notice>: Wake reason: ?

Jun 7 07:31:04 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

Jun 7 07:31:05 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

Jun 7 09:31:23 Seths-MacBook kernel[0] <Notice>: Wake reason: ?

Jun 7 09:31:23 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

Jun 7 09:31:24 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

Jun 7 10:43:55 Seths-MacBook kernel[0] <Notice>: Wake reason: EC.LidOpen (User)

Jun 7 10:43:55 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

Jun 7 10:43:56 Seths-MacBook kernel[0] <Notice>: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)​
 

SethBoy

macrumors regular
Original poster
Jun 23, 2007
217
632
I have turned off Back to my Mac, Find My Mac, Wake on Network Access… just about everything I can think of but it still wakes up during its sleep.

Finally tried turning off WiFi before I put it to sleep, and now it no longer has insomnia. A little annoying I have to remember to turn WiFi on and off before and after going to sleep, but it beats having to shut down the MacBook each time.
 

Queen6

macrumors G4
I have turned off Back to my Mac, Find My Mac, Wake on Network Access… just about everything I can think of but it still wakes up during its sleep.

Finally tried turning off WiFi before I put it to sleep, and now it no longer has insomnia. A little annoying I have to remember to turn WiFi on and off before and after going to sleep, but it beats having to shut down the MacBook each time.

Try this although it`s going to sound rather counter intuitive. Set the Mac not to sleep and leave it powered on overnight with a decent WiFi connection. If the system needs to do something this give it time to complete.

It this a new MacBook to you? if so Mac`s can be finicky with routers, try a different WiFi network and see if you observe the same issues.

All the settings out the box should result in a system that sleeps, WiFi off is telling as it isolates to network interaction. Seems to me that your MacBook is not dropping to hibernation, rather staying in an active sleep mode, for reasons unknown. An option is to reduce the default hibernation wait time from from 3 hours to a lesser value, equally this is more of a workaround than a fix and requires some "surgery" to be done via Terminal.

Outside of Network issues, Bluetooth devices and also wake or prevent some Macs from entering hibernation (deep sleep). I have observed this myself with some of my BT speakers, as some BT peripherals can accept multiple connections; phone & Mac, Mac & Mac etc. When the speaker(s) times out for sleep on my 13" rMBP, it would also wake my rMB, I only caught as one night I was working late and forgot to close the rMB display, so the wakeup was very obvious. BT setting can disable wakeup.

All my primary Mac`s are on 10.10.5, all sleep without issue, while looking at 10.11 I did not observe any issue regarding sleep or hibernation, however I did observe that 10.11 has a more interaction with Apple`s servers than 10.10.

Q-6
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.