MacBook grey screen

Discussion in 'MacBook' started by Seanomck, Jan 27, 2011.

  1. Seanomck macrumors newbie

    Jan 27, 2011
    I need help after I installed a new western digital 640gb hard drive into my thirteen inch unibody MacBook. I formatted the drive and everything and then proceeded to back up my old hard drive from my time capsule and after 4 hours everything was working fine and then it said to redraft my computer. After I did this the computer has been stuck on the same grey screen wi an apple logo and spinning cog or wheel. After I let it sit like this overnight it still did not stop have tried a safe reboot and that didn't work. And I cannot insert the snow leopard cd because it is already in there from the install and i cannot eject it. I still have my old hard drive in case this doesn't work and everything is all backed up. Please help!
  2. miles01110 macrumors Core


    Jul 24, 2006
    The Ivory Tower (I'm not coming down)
    What happens when you hold down "Option" on startup- what startup discs are available?
  3. iPatrick99 macrumors newbie

    Nov 18, 2010
    Westminster, SW1
    I had a similar problem...

    to eject the disc: try rebooting and immediately holding down the trackpad button until the disc ejects. Or, better still, startup holding down 'C' and before you perform an archive/re-install of Mac OS X... launch Disk Utility and Repair the drive first...
  4. Seanomck thread starter macrumors newbie

    Jan 27, 2011
    When I pressed option it gave me The ability to chose Macintosh hd as the hard drive but when I clicked on it it still whent to the grey screen. And when I pressed c it did nothing but I switched back to my old hard drive to eject the snow leopard cd and it worked fine
  5. Seanomck thread starter macrumors newbie

    Jan 27, 2011
    Final Update

    UPDATE: I ended up fixing everything by holding down option while starting up and having the snow leopard cd in and selected that instead of the hard drive. I then re installed snow leopard and reformatted the hard drive and after that i backed up from my time machine. everything works now and instead of 150 gb i now have 640!

Share This Page