Macbook having problems connecting to a secured router

Discussion in 'MacBook Pro' started by -Josh-, Jan 1, 2008.

  1. -Josh- macrumors regular

    Joined:
    Oct 21, 2007
    #1
    I recently called up Belkin and had them walk me through securing my router. I'm sick of allowing the entire neighborhood to download porn on my network.
    All 8 windows machines connect fine, they see the name, they click it, type in a quick password and bam! they're online.
    Everytime I had clicked my routers name, I had a "connection timeout" I tried to get around this by restarting my mac and what not, but nothing worked. Although it was secured, there wasn't even a lock sign next to my name like there is for all the other networks close by. I called up Belkin with my problem and they said to change my router name and try to reconnect. I did that and it worked.
    The problem is, after one night for a handful of ours my macbook disconnects again and I try everything once more, open up airport click my connection name (at this point, again the lock sign is not there) and I get a connection time out. I have to always go to my router settings and change the name in order to use my Macbook for a few consecutive hours.

    Help?!?!
    Thanks you -

    Josh
     
  2. -Josh- thread starter macrumors regular

    Joined:
    Oct 21, 2007
  3. iSwitchd macrumors member

    Joined:
    Aug 21, 2007
    #3
    Happens to me as well.

    My router is hooked up to a windows machine, and my macbook has issues sometimes.

    If I unplug my router for a few seconds and plug it back in...let it boot back up, then I can connect to it.

    I don't know why it does this...but that's the only thing I've found that fixes it.
     
  4. weblogik macrumors regular

    Joined:
    May 7, 2007
    #4
    i have a belkin N1 router on a mbp

    i get like 15mbs download with my unsecure connection, and about 1.5
    /2 mbs with WEP turned on... I just deal with it, and occasionally unsecure it while im on wirelessly...
     

Share This Page