Macbook Headphone jack problem

Discussion in 'MacBook' started by Skakidalex, Mar 15, 2009.

  1. Skakidalex macrumors newbie

    Joined:
    Jan 17, 2008
    Location:
    Ottawa
    #1
    Hello all!

    I've seen this problem on the web before, but nothing is specific enough for my situation. So,

    I haven't used my headphone jack in a while, so I don't exactly know what's going on but, internal speakers work fine, plug in headphones and it doesn't make a sound.

    I know my computer knows there's headphones in the jack because in the system preferences, it registered them, but still no sound. Also, no red light, though I will try the reset button inside.

    I've tried, staying plugged in>removing the battery> restarting>putting the battery back, and nothing. I've tried taking the battery out and back in without the cord and also, nothing.. so.. I'm stuck. All I wanted to do was listen to the funny people in my guild Ventrilo server.

    Any and all help is appreciated :)
     
  2. Skakidalex thread starter macrumors newbie

    Joined:
    Jan 17, 2008
    Location:
    Ottawa
    #2
    I pressed the reset button in the jack, it noticeably stopped my music playing, but when I put the headphones in, still nothing so that's not the answer I guess..
     
  3. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #3
    Might it be the headphones, do they work with other things ... do you have another set to try?
     
  4. Skakidalex thread starter macrumors newbie

    Joined:
    Jan 17, 2008
    Location:
    Ottawa
  5. saadat macrumors member

    saadat

    Joined:
    Nov 30, 2008
    #5
    I too have exactly the same problem....the fault is with the logic board and it needs to be replaced....u can get it replaced for free if ur macbook is under warranty...and if not, it wud cost u $400...

    regards
     
  6. xpected_one macrumors regular

    xpected_one

    Joined:
    Sep 23, 2008
    Location:
    Texas
    #6
    Exactly the same prob here ...Worked fine since I got my MB then sudeenly quit. I reinstalled leopard due to the fact that I upgraded the HDD, and after the install the headphone jack worked again for 1-2 days then quit. So its not necessarily your logic board IMO unless my problem and the reinstall is a coincidence or intermittent??? The only thing I installed on the macbook in those 2 days were Apple updates. Perhaps there could be a problem in one of the updates??
     
  7. saadat macrumors member

    saadat

    Joined:
    Nov 30, 2008
    #7
    keithers i tried reinstalling also, but that didnt help. I also degraded to Tiger 10.4 that came bundled with my macbook, but that too didnt help. And the best way i found was to get it replaced by Apple.
    regards
     
  8. shady825 macrumors 68000

    shady825

    Joined:
    Oct 8, 2008
    Location:
    Area 51
    #8
    Theres a "button" inside the headphone jack??
     
  9. xpected_one macrumors regular

    xpected_one

    Joined:
    Sep 23, 2008
    Location:
    Texas
    #9
    So when you reinstalled ... did it ever work?? Mine did for a couple of days and then decided not to. Im just thinking that it might just be software related and then again each case is different.
     
  10. Skakidalex thread starter macrumors newbie

    Joined:
    Jan 17, 2008
    Location:
    Ottawa
    #10
    ok, well, thanks for the input, I just want to add that, I recently had it repaired because of a cd drive problem, they looked my computer over top to bottom, the whole thing cost me $475 or so, so... if it was the logic board, I think they would have caught it, at least... I hope.
     
  11. saadat macrumors member

    saadat

    Joined:
    Nov 30, 2008
    #11
    NO it didnt. but still if he wants to try he can. Is the red light inside the jack on??? try wiggling the jack with a toothpick....and then see if it works....and if it doesnt, theres no way except to take it to an apple store..
    regards
     

Share This Page