Macbook hooked up to 1080i 22inch HDTV - colour/sound issues.

Discussion in 'Mac Basics and Help' started by Ubuntu, May 1, 2009.

  1. Ubuntu macrumors 68000

    Ubuntu

    Joined:
    Jul 3, 2005
    Location:
    UK/US
    #1
    G'day,

    These aren't major issues, the quality so far has been pretty good, but I've noticed that on the highest resolution, the colours on the monitor seem a bit pale. The letters I am typing right now range from mostly black, but some are red or blue. The monitor isn't amazing quality, but on my Xbox or anything else, the quality is better.

    Is there a way to fix this? I know I can't expect the same quality as that of my macbook, but I would appreciate any help.

    I thought I had 1080p, but it turns out I have 1080i, whats the general difference in quality?

    Also, is there a way to make sounds from movies, etc, come from the TV instead of my macbook?

    Thanks.
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
  3. Ubuntu thread starter macrumors 68000

    Ubuntu

    Joined:
    Jul 3, 2005
    Location:
    UK/US
    #3
    Oh duh, sorry, silly me. I'm using a mini DVI adapter to HDMi, I'm assuming the adapter would result in a bit of quality loss.

    I noticed that when I mirror the display, the text is fine (as its set to the laptop's native resolution), but if I try and change the external display to the macbook resolution (without mirroring), I can only see quarter of my desktop, as if its zoomed in very far. :(
     
  4. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #4
    Take a look at this thread on another forum to see if it helps. I have my Mac Mini hooked up to my 32" LCD using a Mini-DVI > DVI, then a DVI to HDMI cable. I don't notice the issues you mentioned. I think the overscan option that the link talks about may help. Also, if I remember correctly, with a 22" monitor you can't truly display 1080i/p only 720p quality. My 32" only goes to 720p for instance.

    Here's a thread here that may have some nugget of knowledge in it. I didn't read it thoroughly.
     
  5. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    First, as angelwatt is guessing, unless it's a CRT it isn't actually displaying 1080i--it's probably a 720p panel that's converting the 1080i signal. This is probably part of the issue--try setting the Mac to output 720x1280 (I assume that's the right one), which will reduce the likelihood of the TV doing downsampling, which will in turn make the image clearer. Larger, of course, but clearer.

    Nope. It is (or should be) all-digital, so no degradation--all the adapter is doing is rearranging the pins.

    This is what I'm having trouble figuring out. Maybe one of angelwatt's linked threads will lead you in the right direction; I assume your MB has a ~720 display, so the mirroring is setting it to a good resolution for the TV, but I don't know why it would look different when it wasn't mirrored. Overscan issues are one possibility (if your TV has a mode to turn off overscan--"dot by dot" or "computer mode" or something--you definitely want that on), but I'd expect that to just give the image a black border around all four edges, or maybe to cut a bit off (like the menu bar--about 5%-10% on each side).

    Another "maybe" is the Refresh Rate--you probably have an option to change it when outputting to the TV, and maybe you're setting it to something other than 60Hz? (60Hz coupled with 720x1280 is probably what you want to output a 720p signal to a TV.)

    Also, for reference, I assume the color weirdness you're seeing on letters is due to the text display setting on the Mac; it will add sub-pixel colors to letters to make them look crisper, but when you try to rescale this the assumption breaks down and you get all kids of weird artifacts. You can see what it looks like up close by opening Digital Color Meter in your Utilities folder and moving the mouse over some text. If you can't get your Mac to display at the same resolution as the TV text will probably look crisper if you just turn that feature off (set it to "Standard - CRT" in the Appearance pref pane.
     

Share This Page