MacBook hub and sync issues...

Discussion in 'MacBook' started by Dunkrag, Jul 19, 2015.

  1. Dunkrag macrumors regular

    Dunkrag

    Joined:
    Nov 9, 2007
    Location:
    Birmingham, UK
    #1
    Love the new MacBook - downgraded from 15'' retina MacBook pro and not missing anything EXCEPT... The only accessories that I need to plug in are my iPhone 6+, for charge ring and syncing and my 2tb external hard drive that houses my iTunes music library.

    Of course I have the USB-C AV adapter offering a USB port and a non powered hub plugged into that so I can plug in the phone and drive at the same time.

    Real problems since the start with the drive sometimes unmounting, the phone sometimes unmounting, sometimes both unmounting..
    I'd re-sync and all my album artwork would be missing; I'd restore and re-sync, connection would drop, this has all been taking hours!!!!! I have the USB C power lead plugged in all the time.

    I thought the problem was that the hub wasn't powered and not enough juice was getting to the phone and drive, so bought a powered USB hub but the MacBook won't even see the phone or drive with it.

    During all this time too I've upgraded the iOS to 8.4 to include Apple music...
    So I don't really know what the problem is... The MacBook? The phone? The iOS update? The Hub?

    Does anyone have a similar set up that is actually working with a non powered hub? I'm sick of restoring my phone and re-syncing over 20,000 tracks every week..
     
  2. zhenya macrumors 603

    zhenya

    Joined:
    Jan 6, 2005
    #2
    Hmm, I haven't used my setup extensively, but so far I have not had any power issues with the Apple USB-C to digital AV adapter and my Anker 3-port USB/Ethernet adapter. I've had all ports on the Anker filled including with an external 2.5" USB-powered hard disk and they have all worked - no errors. Maybe try a different hub?
     

Share This Page