Macbook internal drive possibly corrupted

Discussion in 'Mac Basics and Help' started by stayposi1990, Mar 23, 2011.

  1. stayposi1990, Mar 23, 2011
    Last edited: Mar 23, 2011

    stayposi1990 macrumors newbie

    Joined:
    Mar 23, 2011
    #1
    Hello MacRumors! I hope this is the right forum.

    I recently bought a used Macbook 3.1 a couple weeks back. It has a 320GB Western Digital Blue Scorpio HDD, running Snow Leopard (can't remember version).

    It has worked perfectly until I stupidly forgot that I had completely discharged the battery earlier, and unplugged the charger within like 5-10 minutes of plugging it in. The computer shut off instantly. :( I smacked myself in the head for being so dumb, then waited at least 20 minutes before connecting it to power again.

    Now, it does not startup - the boot disk cannot be found. :( After long periods of blank-ness (over 10 minutes) I have encountered a solid, non-blinking 'question mark folder' once, and a blinking version once as well (when I held 'x' on startup). I have never seen the 'flashing question mark' by itself, with no folder.

    Otherwise, it only has the blank gray screen. I've never seen the spinning gear or startup icons at this point. The startup chime sounds every time.

    I have tried many PRAM resets, and I attempted SMC/power mgmt. reset but I think I was doing it incorrectly so I will try again when I can - *EDIT* proper SMC reset did not work. Safe Boot doesn't run, when I hold 'option' to choose a drive there is only a cursor - the hard drive is not detected. Verbose and Single User Mode do not work.

    The hard drive is also not detected by my eMac when the Macbook is put into Firewire Disk Target mode. Additionally, when I put the eMac into FDT mode, the Macbook saw it but would not let me select it for start up.

    The computer did not come with any install disks to try and use. :( It does have a warranty in case my HDD is actually dead, but I am more inclined to think its corrupted/software is damaged.

    I don't hear any abnormal noises (clicking, grinds, repeated sounds of failed attempts to work, etc.) from the HDD. I've removed it twice to ensure it wasn't jarred out of place by some unknown force (never been dropped).

    The big problem is that I'm twice-an-idiot - I failed to backup any of my data in time. I kept putting it off. STUPID! :mad:

    Anyone have any advice on how I can possibly fix this? Or else, begin data recovery (either a recommended DIY program or if I should find a pro) or repairs?
    Many thanks.
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    To evaluate the severity of the issue, you will need a Mac OS X Install DVD. If the computer isn't older than 5 years you can order a replacement from Apple, or just buy a copy of 10.6 for $29 U.S. Once you boot to the install DVD (holding C or option and then clicking the disk icon), you can run Disk Utility.
    If the drive shows up (not just showing the optical drive), you can probably fix the issue by running the Verify/Repair Disk commands, reinstalling 10.6 from the DVD, or at worst, reformatting the drive and reinstalling; if it doesn't appear in Disk Utility the drive has likely failed.
    Even if the drive cannot be verified or repaired, you can pull the drive out of the MacBook, put it in an external enclosure and connect it via USB or FireWire to another computer to try recovering your files; or use Target Disk Mode with another Mac. If the drive does not mount or show up in an external enclosure/TDM you can try running DiskWarrior or Prosoft's Data Rescue 3 on the drive. If you want to pay for professional data recovery services you can go with DriveSavers or another service, but it will not be inexpensive. You can also take the computer to an Apple Store or authorized service provider and see if they can perform a complimentary diagnosis to tell you what's wrong, and whatever data recovery service (if any) they offer.
     
  3. stayposi1990, Mar 24, 2011
    Last edited: Mar 24, 2011

    stayposi1990 thread starter macrumors newbie

    Joined:
    Mar 23, 2011
    #3
    Thank you for the reply JediMeister.

    I got a Mac OS X install disc from my dad's 2009/2010 Macbook Pro.

    I held both C and Option on startups and the disc apparently never loaded anything. I heard the SuperDrive doing something each time but nothing ever came up on the screen.

    Is this because I'm unable to use a Macbook Pro's disc on a regular Macbook for some weird reason, or do I seem to have a further issue than I thought?

    *EDIT* I've been doing a lot of reading on similar issues, and apparently certain generations of Macbook cannot boot from CD - even when forced with 'C' startup - if the hard drive is not functioning (a major design flaw). However, supposedly they can boot from CD when the HDD is physically removed from the computer.

    Re-installing the hard drive while the computer is turned on and booted from the install CD (in attempt to bypass the design flaw and then run Disk Utility on it) will only further damage it, correct?

    I will look into DiskWarrior in the meantime.

    Many thanks!
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    Your father's install DVD will not work. Gray labeled discs are system specific. Do you have the ones that the factory would have included with YOUR computer?
    You cannot reseat/reinstall the hard drive while booted up to the DVD. The hard drive is only accessible by removing the battery, and removing a L-shaped bracket.
     
  5. stayposi1990 thread starter macrumors newbie

    Joined:
    Mar 23, 2011
    #5
    Okay, thanks again. I will get both the proper install DVD and DiskWarrior and see what happens, since I should have both anyway, regardless of this problem. :D
     
  6. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #6
    You have to use the disk with YOUR OWN disk.

    If you don't have a disk, go buy Snow Leopard for $29.
     
  7. stayposi1990 thread starter macrumors newbie

    Joined:
    Mar 23, 2011
    #7
    Bought new Snow Leopard install disc, would not boot from the disc with the bad hard drive in the computer, as I expected. Booted fine from disc with the drive taken out.

    Ended up caving and grabbing a 500GB drive from Best Buy, plus an enclosure for the bad drive to sit in until I do something about it.

    Wiped and formatted the new drive, installed, everything works fine.
    Hopefully my old files will be retrieved in the future.

    Thanks for the help guys!
     

Share This Page