Macbook Internal Hard Drive - Cannot be Repaired / Locked

Discussion in 'OS X Yosemite (10.10)' started by immobilus, Jun 18, 2015.

  1. immobilus macrumors member

    Joined:
    May 5, 2012
    #1
    Hello:

    Last night I was cleaning my computer and creating a hard drive image. When I woke up, all was fine. But I noticed the hard drive image was gone without any errors. I went to create another one, with diskutil and it said "permission denied." I did forum searches, and they said to repair permissions. That seems to fix the problem, except in my case I can't do that. It gives me an error saying that the hard drive cannot be verified or repaired.

    I did a Get Info on the drive, and it says I can "read only." I tried to repair it from the command line, and it says:

    Error: -69789: Permissions verify or repair failed
    Underlying error: 26: POSIX reports: Text file busy

    I'm able to create folders, modify files, etc., but the hard drive has me as read only.

    I'm afraid to repair from the boot drive because it may deny me access to log back in if it fails.

    What's going on?
     
  2. immobilus thread starter macrumors member

    Joined:
    May 5, 2012
    #2
    Wow... nothing?

    As a side note, I ended up rebooting. I performed a disk repair permissions from the boot drive. It said there were no issues. So I rebooted. Once logged in, I tried to repair permissions again. It worked, and there were a lot of errors not detected during the boot drive repair attempt. Permissions to create a disk image were restored...

    Until I got about 60% through, then a window popped up saying "permission denied," the disk image disappeared, and I'm back to square one.
     
  3. immobilus thread starter macrumors member

    Joined:
    May 5, 2012
    #3
    Everytime I run repair permissions from the command line, I get the following:

    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired
    ACL found but not expected on "private/var/root/Library/Preferences"
    Repaired "private/var/root/Library/Preferences"
    ACL found but not expected on "private/var/root/Library/Preferences/com.apple.stackshot.plist"
    Repaired "private/var/root/Library/Preferences/com.apple.stackshot.plist"
    ACL found but not expected on "private/var/root/Library/.localized"
    Repaired "private/var/root/Library/.localized"
    ACL found but not expected on "private/var/root/Library/Preferences/.GlobalPreferences.plist"
    Repaired "private/var/root/Library/Preferences/.GlobalPreferences.plist"
    Finished verify/repair permissions on disk1 mac
     
  4. theorist9 macrumors newbie

    Joined:
    May 28, 2015
    #4
    I don't know if this is anything like your issue, but I recently had a permissions problem, and to fix it I had to go into Finder, click on "Macintosh HD", click on the "i" in the circle (get info.), go to the bottom, click on the lock, give it my password, click on plus, choose myself from the drop-down menu, and then give myself Read&Write permissions. I talked to Apple Support, and they said it was OK to do this. Now in your case you might want to go into the finder and do the same for your disk image (if you can do that -- I'm not that familiar with disk images). Not sure if it will fix your problem (and honestly not sure if you should even try it), but I'll just throw that out there for you to consider.
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    Some time ago, I saved some information into my archives pertaining to repairing "locked" hard drives.

    It requires working with terminal.

    Here it is, below. I cannot vouch for the accuracy of the info presented, I paste it here as I saved it:
    =========
    I called Apple and they gave me the solution :

    http://discussions.apple.com/thread....35132&#9035132

    Quote:
    I found a solution that worked.

    In Terminal type the following sequence (obviously replace "Volumename with the name of your volume):

    sudo chflags 0 /Volumes/Volumename
    sudo chown 0:80 /Volumes/Volumename
    sudo chmod 775 /Volumes/Volumename
    sudo chmod -N /Volumes/Volumename
    but if your hard drives name includes a [space] like this: "My HD", then you must write the command like this:

    Quote:
    sudo chflags 0 /Volumes/firstname\ secondname
    sudo chown 0:80 /Volumes/firstname\ secondname
    sudo chmod 775 /Volumes/firstname\ secondname
    sudo chmod -N /Volumes/firstname\ secondname
    or like in my example:

    Quote:
    sudo chflags 0 /Volumes/My\ HD
    sudo chown 0:80 /Volumes/My\ HD
    sudo chmod 775 /Volumes/My\ HD
    sudo chmod -N /Volumes/My\ HD
    It saved both my drives! THANK YOU APPLE!!!



    Originally Posted by angelwatt
    Thanks for posting the solution you found.

    Just to give some more info, for those who care, about the above commands I'll give a brief description of what each line does (as I understand them).
    chflags 0 removes all flags from the file(s)
    chown 0:80 ensures root:admin (owner:group) permissions so the system can access the files
    chmod 775 adjusts file permissions so you and your group have read/write/execute permissions
    chmod -N removes the ACL (Access Control Lists) from the named file(s)
     

Share This Page